aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-03-04 01:23:28 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-03-09 16:00:22 +0000
commitefbee563af4ab56f93ac0a6238426d1d3eb80b98 (patch)
tree99887f8f9783fa9285d336ba93231590779dc2b8
parentd23a1d7df849a2a7d338b2805bba7694717cbe65 (diff)
downloadopenembedded-core-contrib-efbee563af4ab56f93ac0a6238426d1d3eb80b98.tar.gz
bash 3.2.48: disable parallel build
It's Makefile has the two rules: $(BUILTINS_LIBRARY): $(BUILTIN_DEFS) $(BUILTIN_C_SRC) config.h ${BASHINCDIR}/memalloc.h version.h @(cd $(DEFDIR) && $(MAKE) $(MFLAGS) DEBUG=${DEBUG} libbuiltins.a ) || exit 1 ${DEFDIR}/builtext.h: $(BUILTIN_DEFS) @(cd $(DEFDIR) && $(MAKE) $(MFLAGS) builtext.h ) || exit 1 which causes parallel issues: mkbuiltins.o: file not recognized: File truncated collect2: ld returned 1 exit status I don't have any good ideas to fix the problem, so disable parallel build for it. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-extended/bash/bash_3.2.48.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-extended/bash/bash_3.2.48.bb b/meta/recipes-extended/bash/bash_3.2.48.bb
index 35e624bb8b..34272d1e25 100644
--- a/meta/recipes-extended/bash/bash_3.2.48.bb
+++ b/meta/recipes-extended/bash/bash_3.2.48.bb
@@ -41,3 +41,5 @@ SRC_URI[patch056.md5sum] = "222eaa3a2c26f54a15aa5e08817a534a"
SRC_URI[patch056.sha256sum] = "063a8d8d74e4407bf07a32b965b8ef6d213a66abdb6af26cc3584a437a56bbb4"
SRC_URI[patch057.md5sum] = "47d98e3e042892495c5efe54ec6e5913"
SRC_URI[patch057.sha256sum] = "5fc689394d515990f5ea74e2df765fc6e5e42ca44b4591b2c6f9be4b0cadf0f0"
+
+PARALLEL_MAKE = ""