aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZubair Lutfullah Kakakhel <Zubair.Kakakhel@imgtec.com>2016-10-12 13:55:02 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-10-15 09:55:37 +0100
commit49dc626182694d4dd92ed921a8fa2d9cd9f49635 (patch)
treef790a3383b6cbc096256f16178f72a1c6d873dc0
parente6b21d1b3716ee6f4aec1674e56f06b2963a7968 (diff)
downloadopenembedded-core-contrib-49dc626182694d4dd92ed921a8fa2d9cd9f49635.tar.gz
libgpg-error: Make case generic for MIPS
The tuples for MIPS r6 onwards are - mipsisa32r6el - mipsisa32r6 - mipsisa64r6el - mipsisa64r6 The default case passes it forward which isn't handled well and causes a build error. Rework the case statement to make it generic. Signed-off-by: Zubair Lutfullah Kakakhel <Zubair.Kakakhel@imgtec.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-support/libgpg-error/libgpg-error_1.24.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-support/libgpg-error/libgpg-error_1.24.bb b/meta/recipes-support/libgpg-error/libgpg-error_1.24.bb
index e45a7b860a..84a882a0c1 100644
--- a/meta/recipes-support/libgpg-error/libgpg-error_1.24.bb
+++ b/meta/recipes-support/libgpg-error/libgpg-error_1.24.bb
@@ -33,8 +33,8 @@ do_compile_prepend() {
arm) TUPLE=arm-unknown-linux-gnueabi ;;
armeb) TUPLE=arm-unknown-linux-gnueabi ;;
i586|i686) TUPLE=i686-pc-linux-gnu ;;
- mips64el) TUPLE=mipsel-unknown-linux-gnu ;;
- mips64) TUPLE=mips-unknown-linux-gnu ;;
+ mips*el) TUPLE=mipsel-unknown-linux-gnu ;;
+ mips*) TUPLE=mips-unknown-linux-gnu ;;
x86_64) TUPLE=x86_64-pc-linux-gnu ;;
*) TUPLE=${TARGET_ARCH}-unknown-linux-gnu ;;
esac