aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-04-15 19:00:20 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-21 07:19:04 +0100
commit4ac2974f463f8e2970d9e44e3b273c672a3cab8c (patch)
tree8b009bf3fb8c55d4c958b16142d8745a4b634949
parent901114ffb72c14b989690d753298d9db77a126b5 (diff)
downloadopenembedded-core-contrib-4ac2974f463f8e2970d9e44e3b273c672a3cab8c.tar.gz
openssh: Upgrade 6.7 - > 6.8
Its a major releaseof openssh, should be fully compatible with 6.7 additionally works with musl Change-Id: I903d31247b8a318b9be1c21f764ffe56b5971ca9 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-connectivity/openssh/openssh/add-test-support-for-busybox.patch38
-rw-r--r--meta/recipes-connectivity/openssh/openssh_6.8p1.bb (renamed from meta/recipes-connectivity/openssh/openssh_6.7p1.bb)4
2 files changed, 25 insertions, 17 deletions
diff --git a/meta/recipes-connectivity/openssh/openssh/add-test-support-for-busybox.patch b/meta/recipes-connectivity/openssh/openssh/add-test-support-for-busybox.patch
index 07af667869..adc25c668f 100644
--- a/meta/recipes-connectivity/openssh/openssh/add-test-support-for-busybox.patch
+++ b/meta/recipes-connectivity/openssh/openssh/add-test-support-for-busybox.patch
@@ -6,10 +6,12 @@ Adjust test cases to work with busybox.
Signed-off-by: Maxin B. John <maxin.john@enea.com>
Upstream-Status: Pending
---- a/regress/cipher-speed.sh 2012-06-30 07:08:53.000000000 +0200
-+++ b/regress/cipher-speed.sh 2013-02-15 11:30:20.670022055 +0100
-@@ -26,7 +26,7 @@
- echon "$c/$m:\t"
+Index: openssh-6.8p1/regress/cipher-speed.sh
+===================================================================
+--- openssh-6.8p1.orig/regress/cipher-speed.sh
++++ openssh-6.8p1/regress/cipher-speed.sh
+@@ -17,7 +17,7 @@ for c in `${SSH} -Q cipher`; do n=0; for
+ printf "%-60s" "$c/$m:"
( ${SSH} -o 'compression no' \
-F $OBJ/ssh_proxy -2 -m $m -c $c somehost \
- exec sh -c \'"dd of=/dev/null obs=32k"\' \
@@ -17,8 +19,8 @@ Upstream-Status: Pending
< ${DATA} ) 2>&1 | getbytes
if [ $? -ne 0 ]; then
-@@ -42,7 +42,7 @@
- echon "$c:\t"
+@@ -42,7 +42,7 @@ for c in $ciphers; do
+ printf "%-60s" "$c:"
( ${SSH} -o 'compression no' \
-F $OBJ/ssh_proxy -1 -c $c somehost \
- exec sh -c \'"dd of=/dev/null obs=32k"\' \
@@ -26,9 +28,11 @@ Upstream-Status: Pending
< ${DATA} ) 2>&1 | getbytes
if [ $? -ne 0 ]; then
fail "ssh -1 failed with cipher $c"
---- a/regress/transfer.sh 2003-09-04 06:54:40.000000000 +0200
-+++ b/regress/transfer.sh 2013-02-15 11:25:34.666411185 +0100
-@@ -18,7 +18,7 @@
+Index: openssh-6.8p1/regress/transfer.sh
+===================================================================
+--- openssh-6.8p1.orig/regress/transfer.sh
++++ openssh-6.8p1/regress/transfer.sh
+@@ -15,7 +15,7 @@ for p in ${SSH_PROTOCOLS}; do
for s in 10 100 1k 32k 64k 128k 256k; do
trace "proto $p dd-size ${s}"
rm -f ${COPY}
@@ -37,20 +41,24 @@ Upstream-Status: Pending
${SSH} -q -$p -F $OBJ/ssh_proxy somehost "cat > ${COPY}"
if [ $? -ne 0 ]; then
fail "ssh cat $DATA failed"
---- a/regress/yes-head.sh 2005-11-28 06:41:03.000000000 +0100
-+++ b/regress/yes-head.sh 2013-02-15 11:55:11.413715068 +0100
+Index: openssh-6.8p1/regress/yes-head.sh
+===================================================================
+--- openssh-6.8p1.orig/regress/yes-head.sh
++++ openssh-6.8p1/regress/yes-head.sh
@@ -4,7 +4,7 @@
tid="yes pipe head"
- for p in 1 2; do
+ for p in ${SSH_PROTOCOLS}; do
- lines=`${SSH} -$p -F $OBJ/ssh_proxy thishost 'sh -c "while true;do echo yes;done | _POSIX2_VERSION=199209 head -2000"' | (sleep 3 ; wc -l)`
+ lines=`${SSH} -$p -F $OBJ/ssh_proxy thishost 'sh -c "while true;do echo yes;done | _POSIX2_VERSION=199209 head -n 2000"' | (sleep 3 ; wc -l)`
if [ $? -ne 0 ]; then
fail "yes|head test failed"
lines = 0;
---- a/regress/key-options.sh 2008-07-04 09:08:58.000000000 +0200
-+++ b/regress/key-options.sh 2013-02-15 12:06:05.109486098 +0100
-@@ -54,7 +54,7 @@
+Index: openssh-6.8p1/regress/key-options.sh
+===================================================================
+--- openssh-6.8p1.orig/regress/key-options.sh
++++ openssh-6.8p1/regress/key-options.sh
+@@ -54,7 +54,7 @@ for p in ${SSH_PROTOCOLS}; do
fi
sed 's/.*/from="'"$f"'" &/' $origkeys >$authkeys
diff --git a/meta/recipes-connectivity/openssh/openssh_6.7p1.bb b/meta/recipes-connectivity/openssh/openssh_6.8p1.bb
index a2726291fe..8e07e00029 100644
--- a/meta/recipes-connectivity/openssh/openssh_6.7p1.bb
+++ b/meta/recipes-connectivity/openssh/openssh_6.8p1.bb
@@ -25,8 +25,8 @@ SRC_URI = "ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-${PV}.tar.
PAM_SRC_URI = "file://sshd"
-SRC_URI[md5sum] = "3246aa79317b1d23cae783a3bf8275d6"
-SRC_URI[sha256sum] = "b2f8394eae858dabbdef7dac10b99aec00c95462753e80342e530bbb6f725507"
+SRC_URI[md5sum] = "08f72de6751acfbd0892b5f003922701"
+SRC_URI[sha256sum] = "3ff64ce73ee124480b5bf767b9830d7d3c03bbcb6abe716b78f0192c37ce160e"
inherit useradd update-rc.d update-alternatives systemd