aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-06-04 14:44:37 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-07 23:57:11 +0100
commitd0b098a4174ed5d3d61875a3b789d4477ae107ed (patch)
tree8568783adcfbd7c2414f37b646c3705121809a0c
parentb8eeac1b85c253c49f4324ac36db8ff98b286688 (diff)
downloadopenembedded-core-contrib-d0b098a4174ed5d3d61875a3b789d4477ae107ed.tar.gz
squashfs-tools: upgrade to newer revision from git
* 4.3 release has nasty hard to reproduce bug in LZO compression which in few cases results in one of these 2 errors: 1) Lseek failure when creating the FS: | writer: Lseek on destination failed because Bad file descriptor, offset=0x1f72306 | FATAL ERROR:Probably out of space on output filesystem | Parallel mksquashfs: Using 32 processors | Creating 4.0 filesystem on rootfs.squashfs, block size 262144. .. 2) failing to read the filesystem in runtime, kernel 3.16.0 showing errors like this: [ 46.720568] SQUASHFS error: lzo decompression failed, data probably corrupt [ 46.730003] SQUASHFS error: squashfs_read_data failed to read block 0x1f72305 [ 46.740076] SQUASHFS error: Unable to read fragment cache entry [1f72305] it's fixed in upstream git repo: https://github.com/plougher/squashfs-tools/commit/de03266983ceb62e5365aac84fcd3b2fd4d16e6f https://github.com/plougher/squashfs-tools/commit/9c1db6d13a51a2e009f0027ef336ce03624eac0d the official repo is: https://git.kernel.org/cgit/fs/squashfs/squashfs-tools.git but author's github is kept in sync so we can use just that Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb (renamed from meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb)19
1 files changed, 8 insertions, 11 deletions
diff --git a/meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb b/meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb
index 19d555e1e9..497b282074 100644
--- a/meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb
+++ b/meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb
@@ -5,21 +5,18 @@ SECTION = "base"
LICENSE = "GPL-2 & PD"
LIC_FILES_CHKSUM = "file://../COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
file://../../7zC.txt;beginline=12;endline=16;md5=2056cd6d919ebc3807602143c7449a7c \
- "
+"
DEPENDS = "attr zlib xz lzo lz4"
-SRC_URI = "${SOURCEFORGE_MIRROR}/squashfs/squashfs${PV}.tar.gz;name=squashfs \
+PV = "4.3+gitr${SRCPV}"
+SRCREV = "9c1db6d13a51a2e009f0027ef336ce03624eac0d"
+SRC_URI = "git://github.com/plougher/squashfs-tools.git;protocol=https \
http://downloads.sourceforge.net/sevenzip/lzma465.tar.bz2;name=lzma \
- "
-
-SRC_URI[squashfs.md5sum] = "d92ab59aabf5173f2a59089531e30dbf"
-SRC_URI[squashfs.sha256sum] = "0d605512437b1eb800b4736791559295ee5f60177e102e4d4ccd0ee241a5f3f6"
-
+"
SRC_URI[lzma.md5sum] = "29d5ffd03a5a3e51aef6a74e9eafb759"
SRC_URI[lzma.sha256sum] = "c935fd04dd8e0e8c688a3078f3675d699679a90be81c12686837e0880aa0fa1e"
-S = "${WORKDIR}/squashfs${PV}/squashfs-tools"
-SPDX_S = "${WORKDIR}/squashfs${PV}"
+S = "${WORKDIR}/git/squashfs-tools"
# EXTRA_OEMAKE is typically: -e MAKEFLAGS=
# the -e causes problems as CFLAGS is modified in the Makefile, so
@@ -30,8 +27,8 @@ do_compile() {
oe_runmake mksquashfs unsquashfs
}
do_install () {
- install -d ${D}${sbindir}
- install -m 0755 mksquashfs ${D}${sbindir}/
+ install -d ${D}${sbindir}
+ install -m 0755 mksquashfs ${D}${sbindir}/
install -m 0755 unsquashfs ${D}${sbindir}/
}