aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-04-23 20:35:29 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-27 14:57:45 +0100
commitbe5708b077dea2557df1226f7570c4757b68b46d (patch)
tree9589a19b0aa29780bf8cfc68c5d6079db4bec25e
parent7d79a7bfffbc39090b22bb7696cc5dbc832e49b6 (diff)
downloadopenembedded-core-contrib-be5708b077dea2557df1226f7570c4757b68b46d.tar.gz
gummiboot: upgrade 43 -> 48+git
43 does not compile with gcc-5 Refresh objcopy patch to incorporate latest changes Change-Id: Ied41ed1335bb1db3438b98121e05c22242a8a13e Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-bsp/gummiboot/gummiboot/fix-objcopy.patch28
-rw-r--r--meta/recipes-bsp/gummiboot/gummiboot_git.bb4
2 files changed, 19 insertions, 13 deletions
diff --git a/meta/recipes-bsp/gummiboot/gummiboot/fix-objcopy.patch b/meta/recipes-bsp/gummiboot/gummiboot/fix-objcopy.patch
index 2683f835e9..49f55930df 100644
--- a/meta/recipes-bsp/gummiboot/gummiboot/fix-objcopy.patch
+++ b/meta/recipes-bsp/gummiboot/gummiboot/fix-objcopy.patch
@@ -12,10 +12,10 @@ Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Makefile.am | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
-diff --git a/Makefile.am b/Makefile.am
-index d224418..dcd95b0 100644
---- a/Makefile.am
-+++ b/Makefile.am
+Index: git/Makefile.am
+===================================================================
+--- git.orig/Makefile.am
++++ git/Makefile.am
@@ -19,6 +19,8 @@
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
AM_MAKEFLAGS = --no-print-directory
@@ -25,15 +25,21 @@ index d224418..dcd95b0 100644
gummibootlibdir = $(prefix)/lib/gummiboot
AM_CPPFLAGS = -include config.h
-@@ -143,7 +145,7 @@ $(efi_solib): $(efi_objects)
- .DELETE_ON_ERROR: $(efi_solib)
+@@ -148,7 +150,7 @@ $(gummiboot_solib): $(gummiboot_objects)
+ .DELETE_ON_ERROR: $(gummboot_solib)
- $(efi_loadername): $(efi_solib)
+ $(gummiboot): $(gummiboot_solib)
- $(AM_V_GEN) objcopy -j .text -j .sdata -j .data -j .dynamic \
+ $(AM_V_GEN) $(OBJCOPY) -j .text -j .sdata -j .data -j .dynamic \
- -j .dynsym -j .rel -j .rela -j .reloc -j .eh_frame \
+ -j .dynsym -j .rel -j .rela -j .reloc \
+ --target=efi-app-$(ARCH) $< $@
+
+@@ -183,7 +185,7 @@ $(stub_solib): $(stub_objects)
+ .DELETE_ON_ERROR: $(gummboot_solib)
+
+ $(stub): $(stub_solib)
+- $(AM_V_GEN) objcopy -j .text -j .sdata -j .data -j .dynamic \
++ $(AM_V_GEN) $(OBJCOPY) -j .text -j .sdata -j .data -j .dynamic \
+ -j .dynsym -j .rel -j .rela -j .reloc \
--target=efi-app-$(ARCH) $< $@
---
-1.8.3.4
-
diff --git a/meta/recipes-bsp/gummiboot/gummiboot_git.bb b/meta/recipes-bsp/gummiboot/gummiboot_git.bb
index 7fc908e4fe..91c3db9306 100644
--- a/meta/recipes-bsp/gummiboot/gummiboot_git.bb
+++ b/meta/recipes-bsp/gummiboot/gummiboot_git.bb
@@ -9,8 +9,8 @@ DEPENDS = "gnu-efi util-linux"
inherit autotools pkgconfig
inherit deploy
-PV = "43+git${SRCPV}"
-SRCREV = "4062c51075ba054d4949c714fe06123f9ad3097d"
+PV = "48+git${SRCPV}"
+SRCREV = "2bcd919c681c952eb867ef1bdb458f1bc49c2d55"
SRC_URI = "git://anongit.freedesktop.org/gummiboot \
file://fix-objcopy.patch \
"