aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-04-23 20:35:25 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-27 14:57:44 +0100
commit7793b1c425077ed6ed11a9bc2a8b1b96612b1c96 (patch)
tree556da51443d70a93d9156665150658d700271e81
parent2e9a4198fc9a9fcc78eddb6cd5c2ad51a2e8d3e7 (diff)
downloadopenembedded-core-contrib-7793b1c425077ed6ed11a9bc2a8b1b96612b1c96.tar.gz
subversion: Add -P to CPPFLAGS
see https://gcc.gnu.org/gcc-5/porting_to.html we need to stop the preprocessor from generating the #line directives or we run into issues like | checking for apr_int64_t Python/C API format string... | configure: error: failed to recognize APR_INT64_T_FMT on this platform | Configure failed. The contents of all config.log files follows to aid debugging | ERROR: oe_runconf failed Rightly subversion should be fixed but lets leave that to subversion folks Change-Id: I02a89798ff949f79967ab0a73adcddaa4218662d Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/subversion/subversion_1.8.11.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-devtools/subversion/subversion_1.8.11.bb b/meta/recipes-devtools/subversion/subversion_1.8.11.bb
index 8e4cd9df08..d5295d836b 100644
--- a/meta/recipes-devtools/subversion/subversion_1.8.11.bb
+++ b/meta/recipes-devtools/subversion/subversion_1.8.11.bb
@@ -7,7 +7,7 @@ HOMEPAGE = "http://subversion.tigris.org"
BBCLASSEXTEND = "native"
-inherit gettext
+inherit gettext pythonnative
SRC_URI = "${APACHE_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
file://libtool2.patch \
@@ -31,6 +31,7 @@ EXTRA_OECONF = " \
inherit autotools
export LDFLAGS += " -L${STAGING_LIBDIR} "
+CPPFLAGS += "-P"
acpaths = "-I build/ -I build/ac-macros/"