aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2015-02-26 15:27:25 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-27 07:40:27 +0000
commitdd23f79c9ac4782fecc408fc14e66c0ce81f6973 (patch)
tree4670bf55376f28f79a6ce116ec4b156bdbfbe587
parent9c4ab427b6acbc3f708860adace65393562227a7 (diff)
downloadopenembedded-core-contrib-dd23f79c9ac4782fecc408fc14e66c0ce81f6973.tar.gz
python: Fix ctypes/libffi configure
Forces the creation of a configure script for ctypes/libffi Module by calling autoreconf after it being deleted on do_configure(). Fixes configuration hence compilation of this Python module. [YOCTO #7373] Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python-native_2.7.9.bb2
-rw-r--r--meta/recipes-devtools/python/python_2.7.9.bb4
2 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.7.9.bb b/meta/recipes-devtools/python/python-native_2.7.9.bb
index 28aaa111ce..34f5c2914e 100644
--- a/meta/recipes-devtools/python/python-native_2.7.9.bb
+++ b/meta/recipes-devtools/python/python-native_2.7.9.bb
@@ -37,7 +37,7 @@ EXTRA_OEMAKE = '\
STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
'
-do_configure_prepend() {
+do_configure_append() {
autoreconf --verbose --install --force --exclude=autopoint ../Python-${PV}/Modules/_ctypes/libffi
}
diff --git a/meta/recipes-devtools/python/python_2.7.9.bb b/meta/recipes-devtools/python/python_2.7.9.bb
index 048ec3903a..4087c2cb13 100644
--- a/meta/recipes-devtools/python/python_2.7.9.bb
+++ b/meta/recipes-devtools/python/python_2.7.9.bb
@@ -39,9 +39,9 @@ TARGET_CC_ARCH_append_armv7a = " -D__SOFTFP__"
# The following is a hack until we drop ac_cv_sizeof_off_t from site files
EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'ac_cv_sizeof_off_t=8', '', d)} ac_cv_file__dev_ptmx=no ac_cv_file__dev_ptc=no"
-do_configure_prepend() {
+do_configure_append() {
rm -f ${S}/Makefile.orig
- autoreconf -Wcross --verbose --install --force --exclude=autopoint Modules/_ctypes/libffi || bbnote "_ctypes failed to autoreconf"
+ autoreconf -Wcross --verbose --install --force --exclude=autopoint ../Python-${PV}/Modules/_ctypes/libffi
}
do_compile() {