aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLianhao Lu <lianhao.lu@intel.com>2012-04-09 18:32:02 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-10 13:15:59 +0100
commitfdf65d9f12d67f4290b83253efdbb34e5551fbb2 (patch)
tree7e1e7f029d0df5bbeb12605da941b2bc811d1ea5
parent5f1becfba0b801eeacb1c626659fe46cd6df25bf (diff)
downloadopenembedded-core-contrib-fdf65d9f12d67f4290b83253efdbb34e5551fbb2.tar.gz
adt-installer: Fixed ppc kernel naming.
1. Fixed the ppc kernel naming. 2. Disabled opkg shared library to avoid runtime opkg-cl launching error. 3. Adjusted the variable sequence in adt-installer.conf Fixed bug [YOCTO #2233] Signed-off-by: Lianhao Lu <lianhao.lu@intel.com>
-rwxr-xr-xmeta/recipes-devtools/installer/adt-installer/adt_installer4
-rw-r--r--meta/recipes-devtools/installer/adt-installer/adt_installer.conf20
-rw-r--r--meta/recipes-devtools/installer/adt-installer_1.0.bb2
3 files changed, 13 insertions, 13 deletions
diff --git a/meta/recipes-devtools/installer/adt-installer/adt_installer b/meta/recipes-devtools/installer/adt-installer/adt_installer
index 1dd07b7f34..1a53eb9c54 100755
--- a/meta/recipes-devtools/installer/adt-installer/adt_installer
+++ b/meta/recipes-devtools/installer/adt-installer/adt_installer
@@ -170,7 +170,7 @@ if [ ! -x "$LOCAL_OPKG_LOC/bin/opkg-cl" ]; then
check_result
echo_info "Configure opkg ...\n"
- ./autogen.sh --prefix=$parent_folder/$LOCAL_OPKG_LOC --with-opkglibdir=$OPKG_LIBDIR --disable-curl --disable-ssl-curl --disable-gpg --disable-shave >> $parent_folder/$YOCTOADT_INSTALL_LOG_FILE
+ ./autogen.sh --prefix=$parent_folder/$LOCAL_OPKG_LOC --with-opkglibdir=$OPKG_LIBDIR --enable-shared=no --disable-curl --disable-ssl-curl --disable-gpg --disable-shave >> $parent_folder/$YOCTOADT_INSTALL_LOG_FILE
check_result
echo_info "Make opkg ...\n"
@@ -241,7 +241,7 @@ get_qemu_image()
if [ "$1" == "x86" ] || [ "$1" == "x86_64" ]; then
qemu_kernel="bzImage-qemu$target.bin"
- elif [ "$1" == "mips" ]; then
+ elif [ "$1" == "ppc" ] || [ "$1" == "mips" ]; then
qemu_kernel="vmlinux-qemu$target.bin"
else
qemu_kernel="zImage-qemu$target.bin"
diff --git a/meta/recipes-devtools/installer/adt-installer/adt_installer.conf b/meta/recipes-devtools/installer/adt-installer/adt_installer.conf
index 275756e187..afc69a4e7c 100644
--- a/meta/recipes-devtools/installer/adt-installer/adt_installer.conf
+++ b/meta/recipes-devtools/installer/adt-installer/adt_installer.conf
@@ -42,7 +42,7 @@ YOCTOADT_NFS_UTIL="Y"
#YOCTOADT_ROOTFS_$arch is for specifying what root filesystem image files you want to download from the repository. The valid values to replace $arch are: arm, x86, x86_64, powerpc, mips. The valid image files are: minimal, minimal-dev, sato, sato-dev, sato-sdk,lsb, lsb-dev, lsb-sdk. If you want to download multiple images, the entries are space separated
YOCTOADT_ROOTFS_arm="minimal sato-sdk"
#Specify which root filesystem file to use to extract as target sysroot. Please ensure the entry is in the list of downloaded root filesystem files that specified above in YOCTOADT_ROOTFS_$arch
-YOCTOADT_TARGET_SYSROOT_IMAGE_arm="minimal"
+YOCTOADT_TARGET_SYSROOT_IMAGE_arm="sato-sdk"
#The location where the target sysroot will be setup
YOCTOADT_TARGET_SYSROOT_LOC_arm="$HOME/test-yocto/arm"
@@ -52,14 +52,14 @@ YOCTOADT_TARGET_SYSROOT_LOC_arm="$HOME/test-yocto/arm"
#YOCTOADT_TARGET_SYSROOT_LOC_x86="$HOME/test-yocto/x86"
#Here's some template of other arches, which you need to change the value in ""
-#YOCTOADT_TARGET_SYSROOT_IMAGE_x86_64=""
-#YOCTOADT_TARGET_SYSROOT_LOC_x86_64=""
-#YOCTOADT_ROOTFS_x86_64=""
+#YOCTOADT_ROOTFS_x86_64="sato-sdk"
+#YOCTOADT_TARGET_SYSROOT_IMAGE_x86_64="sato-sdk"
+#YOCTOADT_TARGET_SYSROOT_LOC_x86_64="$HOME/test-yocto/x86_64"
-#YOCTOADT_TARGET_SYSROOT_IMAGE_ppc=""
-#YOCTOADT_TARGET_SYSROOT_LOC_ppc=""
-#YOCTOADT_ROOTFS_ppc=""
+#YOCTOADT_ROOTFS_ppc="sato-sdk"
+#YOCTOADT_TARGET_SYSROOT_IMAGE_ppc="sato-sdk"
+#YOCTOADT_TARGET_SYSROOT_LOC_ppc="$HOME/test-yocto/ppc"
-#YOCTOADT_TARGET_SYSROOT_IMAGE_mips=""
-#YOCTOADT_TARGET_SYSROOT_LOC_mips=""
-#YOCTOADT_ROOTFS_mips=""
+#YOCTOADT_ROOTFS_mips="sato-sdk"
+#YOCTOADT_TARGET_SYSROOT_IMAGE_mips="sato-sdk"
+#YOCTOADT_TARGET_SYSROOT_LOC_mips="$HOME/test-yocto/mips"
diff --git a/meta/recipes-devtools/installer/adt-installer_1.0.bb b/meta/recipes-devtools/installer/adt-installer_1.0.bb
index 07bef882d8..5dc0896e5e 100644
--- a/meta/recipes-devtools/installer/adt-installer_1.0.bb
+++ b/meta/recipes-devtools/installer/adt-installer_1.0.bb
@@ -30,7 +30,7 @@ ALLOW_EMPTY = "1"
PACKAGES = ""
-PR = "r8"
+PR = "r9"
ADT_DEPLOY = "${TMPDIR}/deploy/sdk/"
ADT_DIR = "${WORKDIR}/adt-installer/"