aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiaofeng Yan <xiaofeng.yan@windriver.com>2012-04-09 15:16:32 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-10 13:16:00 +0100
commit700fc9a5d25ebb1f85cb9db11e41ba502744fe7e (patch)
tree4e87d680d598775c6a8921bc5193878c8e925613
parentfdf65d9f12d67f4290b83253efdbb34e5551fbb2 (diff)
downloadopenembedded-core-contrib-700fc9a5d25ebb1f85cb9db11e41ba502744fe7e.tar.gz
opkg: Add the condition for the content of arch.conf when enable multilib
After successfully installed some lib32 multilib packages into the x86-64 image, we just found that the file content of /var/lib/opkg/status in rootfs changed after the very 1st boot, many lib32 related packages information are missing in that file. The missing arch "x86" in arch.conf cause the above problem. Adding the condition for the content of arch.conf when enable multilib. If build multilib image, "ALL_MULTILIB_PACKAGE_ARCHS" will be used instead of "PACKAGE_ARCHS". [YOCTO #1522] Signed-off-by: Xiaofeng Yan <xiaofeng.yan@windriver.com>
-rw-r--r--meta/recipes-devtools/opkg/opkg-config-base_1.0.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-devtools/opkg/opkg-config-base_1.0.bb b/meta/recipes-devtools/opkg/opkg-config-base_1.0.bb
index 3a559cb57d..f37b2db27d 100644
--- a/meta/recipes-devtools/opkg/opkg-config-base_1.0.bb
+++ b/meta/recipes-devtools/opkg/opkg-config-base_1.0.bb
@@ -9,7 +9,12 @@ do_compile() {
archconf=${S}/${sysconfdir}/opkg/arch.conf
rm -f $archconf
- ipkgarchs="${PACKAGE_ARCHS}"
+ multilibs="${@d.getVar('MULTILIBS',True)}"
+ if [ "X${multilibs}" == "XNone" ]; then
+ ipkgarchs="${PACKAGE_ARCHS}"
+ else
+ ipkgarchs="${ALL_MULTILIB_PACKAGE_ARCHS}"
+ fi
priority=1
for arch in $ipkgarchs; do
echo "arch $arch $priority" >> $archconf