aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrew Moseley <drew_moseley@mentor.com>2014-11-26 19:49:54 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-05 17:42:46 +0000
commit9245cb4fe211da06283d53086bca3fcd5b2c8aef (patch)
tree70885fd0a41debb74f8ffbc2897c99310ee2d794
parent505a3a6a9a0c080bc5b7d16ed569b80b43869977 (diff)
downloadopenembedded-core-contrib-9245cb4fe211da06283d53086bca3fcd5b2c8aef.tar.gz
openembedded-core-contrib-9245cb4fe211da06283d53086bca3fcd5b2c8aef.tar.bz2
openembedded-core-contrib-9245cb4fe211da06283d53086bca3fcd5b2c8aef.zip
glew: Additional fix for generation of glew.pc.
Without this fix, building mesa-demos with the glew PACKAGECONFIG will result in errors like the below being logged in tmp/work/*/mesa-demos/*/build/config.log: configure:16529: checking for GLEW configure:16536: $PKG_CONFIG --exists --print-errors "glew >= 1.5.4" Package @requireslib@ was not found in the pkg-config search path. Perhaps you should add the directory containing `@requireslib@.pc' to the PKG_CONFIG_PATH environment variable Package '@requireslib@', required by 'glew', not found configure:16539: $? = 1 Signed-off-by: Drew Moseley <drew_moseley@mentor.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-graphics/glew/glew/fix-glew.pc-install.patch3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-graphics/glew/glew/fix-glew.pc-install.patch b/meta/recipes-graphics/glew/glew/fix-glew.pc-install.patch
index a20fbfce00a..70a99aeeeeb 100644
--- a/meta/recipes-graphics/glew/glew/fix-glew.pc-install.patch
+++ b/meta/recipes-graphics/glew/glew/fix-glew.pc-install.patch
@@ -39,7 +39,8 @@ Index: glew-1.11.0/glew.pc.in
-Version: @version@
-Cflags: -I${includedir} @cflags@
-Libs: -L${libdir} -l@libname@
+-Requires: @requireslib@
+Version: @VERSION@
+Cflags: -I${includedir} @CFLAGS@
+Libs: -L${libdir} -lGLEW
- Requires: @requireslib@
++Requires: glu