aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-04-01 20:09:25 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-04-03 15:51:09 +0100
commit967009e91472db109bb94c8f865924fef1beaa22 (patch)
tree208a91136549792b33de94419540e69161cb4c01
parent11cf8cb05975dda23370b7715872bc4a191a2ff6 (diff)
downloadopenembedded-core-contrib-967009e91472db109bb94c8f865924fef1beaa22.tar.gz
linux-yocto/4.4: UVC: Add support for R200 depth camera
Integrating the following commit: [ Add support for Intel R200 depth camera in uvc driver. This includes adding new uvc GUIDs for the new pixel formats, adding new V4L pixel format definition to user api headers, and updating the uvc driver GUID-to-4cc tables with the new formats. Tested-by: Greenberg, Aviv D <aviv.d.greenberg@intel.com> Signed-off-by: Aviv Greenberg <aviv.d.greenberg@intel.com> Signed-off-by: Sakari Ailus <sakari.ailus@linux.intel.com> Signed-off-by: Guennadi Liakhovetski <g.liakhovetski@gmx.de> Signed-off-by: Mauro Carvalho Chehab <mchehab@osg.samsung.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> ] Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.4.bb16
3 files changed, 10 insertions, 10 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb
index a3b743b1d9..87b46e48c5 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb
@@ -2,7 +2,7 @@ KBRANCH ?= "standard/preempt-rt"
require recipes-kernel/linux/linux-yocto.inc
-SRCREV_machine ?= "1970b2704b881effa78c3e5f79c0fd3bff1fd028"
+SRCREV_machine ?= "8611de4e967b16bd5b63714045329d621ee744d0"
SRCREV_meta ?= "770996a263e22562c81f48fde0f0dc647156abce"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.4.git;branch=${KBRANCH};name=machine \
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb
index 67e261c6a6..9446da9893 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb
@@ -9,7 +9,7 @@ LINUX_VERSION ?= "4.4.3"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "bc22b90fb5834ead65c31ca0d1e117239d4b545d"
+SRCREV_machine ?= "73481a3abd4ee49c1cf5561fea997275f535098e"
SRCREV_meta ?= "770996a263e22562c81f48fde0f0dc647156abce"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.4.bb b/meta/recipes-kernel/linux/linux-yocto_4.4.bb
index 0494564a5b..7aeb7c35db 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.4.bb
@@ -11,14 +11,14 @@ KBRANCH_qemux86 ?= "standard/base"
KBRANCH_qemux86-64 ?= "standard/base"
KBRANCH_qemumips64 ?= "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "8abee78b727ce6a4df262d1befcbecfa26742ae0"
-SRCREV_machine_qemuarm64 ?= "bc22b90fb5834ead65c31ca0d1e117239d4b545d"
-SRCREV_machine_qemumips ?= "475e28c3240610c26ee0b7866dc0ce701d0c27e1"
-SRCREV_machine_qemuppc ?= "bc22b90fb5834ead65c31ca0d1e117239d4b545d"
-SRCREV_machine_qemux86 ?= "bc22b90fb5834ead65c31ca0d1e117239d4b545d"
-SRCREV_machine_qemux86-64 ?= "bc22b90fb5834ead65c31ca0d1e117239d4b545d"
-SRCREV_machine_qemumips64 ?= "8d34fd84b9c53507b3d10a4a44294c479237319c"
-SRCREV_machine ?= "bc22b90fb5834ead65c31ca0d1e117239d4b545d"
+SRCREV_machine_qemuarm ?= "8809b2c36a60829bb9a7c3b04cdf42e95d8e93ae"
+SRCREV_machine_qemuarm64 ?= "73481a3abd4ee49c1cf5561fea997275f535098e"
+SRCREV_machine_qemumips ?= "6a62ed62536c0f50050e24ee385b9e3965d43c97"
+SRCREV_machine_qemuppc ?= "73481a3abd4ee49c1cf5561fea997275f535098e"
+SRCREV_machine_qemux86 ?= "73481a3abd4ee49c1cf5561fea997275f535098e"
+SRCREV_machine_qemux86-64 ?= "73481a3abd4ee49c1cf5561fea997275f535098e"
+SRCREV_machine_qemumips64 ?= "c61be23279c09c6906571de734b583dc7eacedc6"
+SRCREV_machine ?= "73481a3abd4ee49c1cf5561fea997275f535098e"
SRCREV_meta ?= "770996a263e22562c81f48fde0f0dc647156abce"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.4.git;name=machine;branch=${KBRANCH}; \