aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2013-12-04 18:32:43 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-11 12:00:39 +0000
commit7c161e05fcbe92a5ac076d8611f6237ca69d34f7 (patch)
tree7732043f68fa7632da290bbaf18528167471877b
parentcf978595ae0563c26dcaaa03059ab54a744dbc35 (diff)
downloadopenembedded-core-contrib-7c161e05fcbe92a5ac076d8611f6237ca69d34f7.tar.gz
cpan-base: Add vardepvalue to get_perl_version function
* without this bitbake -S perf shows following error: ERROR: Bitbake's cached basehash does not match the one we just generated (/OE/oe-core/meta/recipes-kernel/perf/perf.bb.do_package)! if you run it twice, once without perl in sysroot and once with perl already built (From OE-Core master rev: f31f6a70ec24e8c9515d69c5092e15effc5e7d4d) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/classes/cpan-base.bbclass3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/classes/cpan-base.bbclass b/meta/classes/cpan-base.bbclass
index 7e1e8d0d6b..aa502d5faa 100644
--- a/meta/classes/cpan-base.bbclass
+++ b/meta/classes/cpan-base.bbclass
@@ -10,6 +10,9 @@ RDEPENDS_${PN} += "${@["perl", ""][(bb.data.inherits_class('native', d))]}"
PERL_OWN_DIR = "${@["", "/perl-native"][(bb.data.inherits_class('native', d))]}"
# Determine the staged version of perl from the perl configuration file
+# Assign vardepvalue, because otherwise signature is changed before and after
+# perl is built (from None to real version in config.sh).
+get_perl_version[vardepvalue] = "${PERL_OWN_DIR}"
def get_perl_version(d):
import re
cfg = d.expand('${STAGING_LIBDIR}${PERL_OWN_DIR}/perl/config.sh')