aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2014-06-05 17:09:05 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-06 09:32:25 +0100
commitca220681f1ba0fedeab68e96df58f36c4fbc7473 (patch)
treee2c17eced480418a122adffcb18f5eee27fdee9b
parentbf6fcfa17d73171623a4d27089c32031705c2591 (diff)
downloadopenembedded-core-contrib-ca220681f1ba0fedeab68e96df58f36c4fbc7473.tar.gz
fontconfig: enable 64 bit file support
When running 32bit code on a large filessytem with 64bit inodes, the fontcache was not being created correctly because an EOVERFLOW was being returned from the fstat when reading the 64 inode on a 32bit system. The fontcache is created at rootfs time on the host system via qemu. [YOCTO #6338] Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/fontconfig/fontconfig_2.11.0.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-graphics/fontconfig/fontconfig_2.11.0.bb b/meta/recipes-graphics/fontconfig/fontconfig_2.11.0.bb
index 48385a369a..7e8708f873 100644
--- a/meta/recipes-graphics/fontconfig/fontconfig_2.11.0.bb
+++ b/meta/recipes-graphics/fontconfig/fontconfig_2.11.0.bb
@@ -38,5 +38,7 @@ DEBIAN_NOAUTONAME_fontconfig-utils = "1"
inherit autotools pkgconfig
EXTRA_OECONF = " --disable-docs --with-default-fonts=${datadir}/fonts"
+TARGET_CPPFLAGS += "-D_FILE_OFFSET_BITS=64"
+
BBCLASSEXTEND = "native"