aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2014-06-05 17:09:04 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-06 09:32:04 +0100
commit65121c8ab37907938b1891b5ee8fb44fb4f76d8f (patch)
tree837aec7e17f36e03bf8cb869bbf2c8e2b608718a
parentdd9c3d7bc946ff44e0ca90f4e345711d6ad21728 (diff)
downloadopenembedded-core-contrib-65121c8ab37907938b1891b5ee8fb44fb4f76d8f.tar.gz
freetype: enable 64 bit file support
When running 32bit code on a large filessytem with 64bit inodes, the fontcache was not being created correctly because an EOVERFLOW was being returned from the fstat when reading the 64 inode on a 32bit system. The fontcache is created at rootfs time on the host system via qemu. [YOCTO #6338] Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/freetype/freetype_2.5.3.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-graphics/freetype/freetype_2.5.3.bb b/meta/recipes-graphics/freetype/freetype_2.5.3.bb
index 5d239e85fa..122b8c04da 100644
--- a/meta/recipes-graphics/freetype/freetype_2.5.3.bb
+++ b/meta/recipes-graphics/freetype/freetype_2.5.3.bb
@@ -23,6 +23,8 @@ LIBTOOL = "${S}/builds/unix/${HOST_SYS}-libtool"
EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
EXTRA_OEMAKE_class-native = ""
EXTRA_OECONF = "--without-zlib --without-bzip2 CC_BUILD='${BUILD_CC}'"
+TARGET_CPPFLAGS += "-D_FILE_OFFSET_BITS=64"
+
PACKAGECONFIG ??= ""
PACKAGECONFIG[pixmap] = "--with-png,--without-png,libpng"