aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2014-06-06 16:26:25 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-06 10:21:20 +0100
commit4fad24fef5552bd0e4a5ea0982573ba8e4523570 (patch)
tree6e82605f92b4cedd0019b5aecb17433a03b632a3
parent9f363f9e2a56d847efc37dfba38764ae393fbfd6 (diff)
downloadopenembedded-core-contrib-4fad24fef5552bd0e4a5ea0982573ba8e4523570.tar.gz
grub-2.00: remove our 40_custom
We have this in recipes-bsp/grub/grub/40_custom: [snip] menuentry "Linux" { set root=(hd0,1) linux /vmlinuz root=__ROOTFS__ rw __CONSOLE__ __VIDEO_MODE__ __VGA_MODE__ quiet } [snip] These lines are only for initrdscripts/files/init-install.sh, the side effect is that it would make the target's grub-mkconfig doesn't work well since the 40_custom will be installed to /etc/grub.d/40_custom, the grub-mkconfig will run the 40_custom, and there will always be a 'menuentry "Linux"' menu in grub.cfg no matter it is valid or not, we can do this in init-install.sh rather than grub to fix the problem, which is also much simpler. We have done the related work in init-install.sh, now we need remove our own 40_custom, and use grub's own 40_custom which is the right one. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rwxr-xr-xmeta/recipes-bsp/grub/grub/40_custom9
-rw-r--r--meta/recipes-bsp/grub/grub_2.00.bb2
-rw-r--r--meta/recipes-bsp/grub/grub_git.bb2
3 files changed, 0 insertions, 13 deletions
diff --git a/meta/recipes-bsp/grub/grub/40_custom b/meta/recipes-bsp/grub/grub/40_custom
deleted file mode 100755
index f891b02779..0000000000
--- a/meta/recipes-bsp/grub/grub/40_custom
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/sh
-exec tail -n +3 $0
-# This file provides an easy way to add custom menu entries. Simply type the
-# menu entries you want to add after this comment. Be careful not to change
-# the 'exec tail' line above.
-menuentry "Linux" {
- set root=(hd0,1)
- linux /vmlinuz root=__ROOTFS__ rw __CONSOLE__ __VIDEO_MODE__ __VGA_MODE__ quiet
-}
diff --git a/meta/recipes-bsp/grub/grub_2.00.bb b/meta/recipes-bsp/grub/grub_2.00.bb
index 6075b20bdc..ce2d680eec 100644
--- a/meta/recipes-bsp/grub/grub_2.00.bb
+++ b/meta/recipes-bsp/grub/grub_2.00.bb
@@ -20,7 +20,6 @@ SRC_URI = "ftp://ftp.gnu.org/gnu/grub/grub-${PV}.tar.gz \
file://grub-2.00-fpmath-sse-387-fix.patch \
file://remove-gets.patch \
file://check-if-liblzma-is-disabled.patch \
- file://40_custom \
file://fix-issue-with-flex-2.5.37.patch \
file://grub-2.00-add-oe-kernel.patch \
"
@@ -44,7 +43,6 @@ EXTRA_OECONF = "--with-platform=pc --disable-grub-mkfont --program-prefix="" \
do_install_append () {
install -d ${D}${sysconfdir}/grub.d
- install -m 0755 ${WORKDIR}/40_custom ${D}${sysconfdir}/grub.d/40_custom
}
INSANE_SKIP_${PN} = "arch"
diff --git a/meta/recipes-bsp/grub/grub_git.bb b/meta/recipes-bsp/grub/grub_git.bb
index 3edc20a856..7f89739179 100644
--- a/meta/recipes-bsp/grub/grub_git.bb
+++ b/meta/recipes-bsp/grub/grub_git.bb
@@ -19,7 +19,6 @@ DEFAULT_PREFERENCE_arm = "1"
PV = "2.00+${SRCPV}"
SRCREV = "4b8b9135f1676924a8458da528d264bbc7bbb301"
SRC_URI = "git://git.savannah.gnu.org/grub.git \
- file://40_custom \
file://autogen.sh-exclude-pc.patch \
file://grub-2.00-add-oe-kernel.patch \
file://asciih-fix-build-warning-error.patch \
@@ -52,7 +51,6 @@ do_configure_prepend() {
do_install_append () {
install -d ${D}${sysconfdir}/grub.d
- install -m 0755 ${WORKDIR}/40_custom ${D}${sysconfdir}/grub.d/40_custom
}