aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2014-12-09 15:05:35 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-11 11:26:08 +0000
commitf5bc0ba35ac531feae2e84bbc4f9d16f861db6c6 (patch)
treefceeab553c4fba4bf5b30b4925bb1ad75463cb0e
parent65e15a1d4304bd3677a79d9b4c5a7a771dfd42d5 (diff)
downloadopenembedded-core-contrib-f5bc0ba35ac531feae2e84bbc4f9d16f861db6c6.tar.gz
python-pycurl: build docstrings to fix rebuilds
On a rebuild base.bbclass will invoke "make clean" to ensure that old build objects are not used. This will delete docstrings.c and the only way to re-generate that is with a dedicated setup.py target. Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/python/python-pycurl_7.19.5.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-pycurl_7.19.5.bb b/meta/recipes-devtools/python/python-pycurl_7.19.5.bb
index a21a426dbb..e4619c740e 100644
--- a/meta/recipes-devtools/python/python-pycurl_7.19.5.bb
+++ b/meta/recipes-devtools/python/python-pycurl_7.19.5.bb
@@ -29,6 +29,11 @@ export STAGING_LIBDIR
BBCLASSEXTEND = "native"
+# Ensure the docstrings are generated as make clean will remove them
+do_compile_prepend() {
+ ${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py docstrings
+}
+
do_install_append() {
rm -rf ${D}${datadir}/share
}