aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2014-02-11 10:54:54 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-11 17:15:48 +0000
commit2325c1ee13bc3a8474238e8a6c20b6a3c671bf07 (patch)
tree624879a9d5869c39200c409c773f1640b340b4ef
parent09706953cf0e1b97d5b8808bdca1e8c125b8a9f7 (diff)
downloadopenembedded-core-contrib-2325c1ee13bc3a8474238e8a6c20b6a3c671bf07.tar.gz
curl: fix https certificate problems
point CA bundle to /etc/ssl/certs/ca-certificates.crt instead of using the buildhost location, Configure would look at the buildhost and hardcode the bundle location for there into the target. This leads to non-working https support. Also remove the empty and now useless curl-certs packages since it's empty and no ALLOW_EMPTY has been set. Apart from making https work again with curl cmdline this also fixes libcurl which means git can fetch https repos as well instead of erroring out. Signed-off-by: Koen Kooi <koen.kooi@linaro.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/curl/curl_7.34.0.bb8
1 files changed, 3 insertions, 5 deletions
diff --git a/meta/recipes-support/curl/curl_7.34.0.bb b/meta/recipes-support/curl/curl_7.34.0.bb
index b49c6e442a..aba6649a66 100644
--- a/meta/recipes-support/curl/curl_7.34.0.bb
+++ b/meta/recipes-support/curl/curl_7.34.0.bb
@@ -30,6 +30,7 @@ EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \
--enable-crypto-auth \
--disable-ldap \
--disable-ldaps \
+ --with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \
${CURLGNUTLS} \
"
@@ -45,13 +46,10 @@ do_install_append() {
oe_multilib_header curl/curlbuild.h
}
-PACKAGES =+ "${PN}-certs libcurl libcurl-dev libcurl-staticdev libcurl-doc"
-
-FILES_${PN}-certs = "${datadir}/curl/curl-*"
-PACKAGE_ARCH_${PN}-certs = "all"
+PACKAGES =+ "libcurl libcurl-dev libcurl-staticdev libcurl-doc"
FILES_lib${BPN} = "${libdir}/lib*.so.*"
-RRECOMMENDS_lib${BPN} += "${PN}-certs"
+RRECOMMENDS_lib${BPN} += "ca-certificates"
FILES_lib${BPN}-dev = "${includedir} \
${libdir}/lib*.so \
${libdir}/lib*.la \