aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-05-12 22:42:23 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-05-16 00:09:47 +0300
commita4c4f38091ed397a4ced625734e947be79c6c2bf (patch)
tree7c82163fb23a8ca9cf4c1f65e188bc047ca09a76
parent4520feca657ac543267b4c8840e57bb32baf18c3 (diff)
downloadopenembedded-core-contrib-a4c4f38091ed397a4ced625734e947be79c6c2bf.tar.gz
linux-yocto: add qemumips64 compatibility
The 3.8 and linux-yocto-dev kernel trees carry qemumips64 support. Adding the board to the compatibility directly in the recipes is the first step to adding mips64 support to the broader set of packages. (From OE-Core rev: 0b4187fac16f78a1f9ba1c696edbc8c2aa189cb1) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-dev.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.8.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-dev.bb b/meta/recipes-kernel/linux/linux-yocto-dev.bb
index fdea085b53..598c82c84d 100644
--- a/meta/recipes-kernel/linux/linux-yocto-dev.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-dev.bb
@@ -38,7 +38,7 @@ LINUX_VERSION_EXTENSION ?= "-yoctodev-${LINUX_KERNEL_TYPE}"
PR = "r0"
PV = "${LINUX_VERSION}+git${SRCPV}"
-COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64)"
+COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemumips64|qemux86-64)"
# Functionality flags
KERNEL_FEATURES_append = " features/netfilter/netfilter.scc"
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.8.bb b/meta/recipes-kernel/linux/linux-yocto_3.8.bb
index 2fcadddccf..b79fa4e21d 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.8.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.8.bb
@@ -20,7 +20,7 @@ PV = "${LINUX_VERSION}+git${SRCPV}"
KMETA = "meta"
-COMPATIBLE_MACHINE = "qemuarm|qemux86|qemuppc|qemumips|qemux86-64"
+COMPATIBLE_MACHINE = "qemuarm|qemux86|qemuppc|qemumips|qemumips64|qemux86-64"
# Functionality flags
KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"