aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2015-05-04 09:43:00 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-07 13:40:34 +0100
commit6599783b85396004c2b8d5fc1ae0fafbaf8af625 (patch)
tree11ff2c01aa0560d36f5a0df955eaf5dfba4561d4
parent0be72c2fb5621d365ff49bbf7e017ce796bd27a0 (diff)
downloadopenembedded-core-contrib-6599783b85396004c2b8d5fc1ae0fafbaf8af625.tar.gz
python3-native: Disable pip on native builds to fix Autobuilder issues
As Python-3.4 pip is required and installed by default, pips installation is bootstrapped using python wheels, this makes it complicated to patch and causes errors on the Autobuilders, since we don't need pip for python3-native, this disables it fixing the issues. (From OE-Core rev: f279f1df6429b0f76e5354c6f0f0b5c29f558edd) Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python3-native_3.4.2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3-native_3.4.2.bb b/meta/recipes-devtools/python/python3-native_3.4.2.bb
index 37399be69c..463957f8c1 100644
--- a/meta/recipes-devtools/python/python3-native_3.4.2.bb
+++ b/meta/recipes-devtools/python/python3-native_3.4.2.bb
@@ -42,7 +42,7 @@ inherit native
RPROVIDES += "python3-distutils-native python3-compression-native python3-textutils-native python3-core-native"
-EXTRA_OECONF_append = " --bindir=${bindir}/${PN}"
+EXTRA_OECONF_append = " --bindir=${bindir}/${PN} --without-ensurepip"
EXTRA_OEMAKE = '\
BUILD_SYS="" \