aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-09-22 21:31:39 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-10-10 18:17:53 +0100
commitea4010c8398745736b0c22ed037604db8fc43212 (patch)
tree9b8c7212fe8281e693754556c31c1c94253b3929
parent5f225067dcb7244065f857d34e1041171844b243 (diff)
downloadopenembedded-core-contrib-ea4010c8398745736b0c22ed037604db8fc43212.tar.gz
ncurses: enable-pc-files requires PKG_CONFIG_LIBDIR existed
Fixed ncurses.do_configure: configure: WARNING: did not find library /path/to/tmp/sysroots/qemuarm/usr/lib/pkgconfig And then anyone requires ncurses.pc will fail. The configure.in checks: [snip] if test -n "$PKG_CONFIG_LIBDIR" && test -d "$PKG_CONFIG_LIBDIR" ; then [snip] Create PKG_CONFIG_LIBDIR in do_configure will fix the problem. We can reproduce the problem by: Set SSTATE_DIR=/path/to/sstate-cache 1) In build1, make sure everything is ready in SSTATE_DIR $ bitbake ncurses 2) In build2, rebuild ncurses only: $ bitbake ncurses -ccleansstate && bitbake ncurses Then we will see the warning in log.do_configure. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/ncurses/ncurses.inc2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-core/ncurses/ncurses.inc b/meta/recipes-core/ncurses/ncurses.inc
index 521d0e435c..10f7dd175d 100644
--- a/meta/recipes-core/ncurses/ncurses.inc
+++ b/meta/recipes-core/ncurses/ncurses.inc
@@ -98,6 +98,8 @@ do_configure() {
# not the case for /dev/null redirections)
export cf_cv_working_poll=yes
+ # The --enable-pc-files requires PKG_CONFIG_LIBDIR existed
+ mkdir -p ${PKG_CONFIG_LIBDIR}
( cd ${S}; gnu-configize --force )
ncurses_configure "narrowc" || \
return 1