aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2014-10-11 16:59:22 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-10-18 16:12:55 +0200
commit69a3ab38d1c725c2b575065739cae4a3b45015a2 (patch)
treec2c86bfdfdfa72a2b6809944a8c9a5dcc67d174e
parent3c238dff41fbd3687457989c7b17d22b2cc844be (diff)
downloadopenembedded-core-contrib-69a3ab38d1c725c2b575065739cae4a3b45015a2.tar.gz
file: add wrapper to nativesdk-file
"file" command in exported SDK doesn't work: ... $ file sysroots/ file: could not find any valid magic files! ... In oe-core commit 68d548cbae729eaea8ce1403dc95ff63c4a7375c, it added wrapper to file-native. Do the same thing for nativesdk-file. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/file/file_5.18.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-devtools/file/file_5.18.bb b/meta/recipes-devtools/file/file_5.18.bb
index f2f8d032e2..9068b9314a 100644
--- a/meta/recipes-devtools/file/file_5.18.bb
+++ b/meta/recipes-devtools/file/file_5.18.bb
@@ -27,4 +27,9 @@ do_install_append_class-native() {
--magic-file ${datadir}/misc/magic.mgc
}
+do_install_append_class-nativesdk() {
+ create_cmdline_wrapper ${D}/${bindir}/file \
+ --magic-file ${datadir}/misc/magic.mgc
+}
+
BBCLASSEXTEND = "native nativesdk"