aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorIoan-Adrian Ratiu <adrian.ratiu@ni.com>2016-01-05 14:24:23 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-07 13:40:09 +0000
commitcfd1e4bcd66a9a542007115647cadb8480330fab (patch)
treee38e200e09cbc9a0020f9a584dae51452349b970
parent210b40b694e5ab03537c02baba453c9cdd11f4e0 (diff)
downloadopenembedded-core-contrib-cfd1e4bcd66a9a542007115647cadb8480330fab.tar.gz
x11vnc: remove all references to moved package
Together with the move to meta-oe, all references to x11vnc should be removed from oe-core. There are three of these: a distro alias, a packagegroup rdepends and a runtime test. Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/conf/distro/include/distro_alias.inc1
-rw-r--r--meta/lib/oeqa/runtime/vnc.py20
-rw-r--r--meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb2
3 files changed, 0 insertions, 23 deletions
diff --git a/meta/conf/distro/include/distro_alias.inc b/meta/conf/distro/include/distro_alias.inc
index 530917760a..0a213ba2e4 100644
--- a/meta/conf/distro/include/distro_alias.inc
+++ b/meta/conf/distro/include/distro_alias.inc
@@ -416,7 +416,6 @@ DISTRO_PN_ALIAS_pn-which = "Mandriva=which Fedora=which"
DISTRO_PN_ALIAS_pn-wpa-supplicant = "Meego=wpa_supplicant Fedora=wpa_supplicant OpenSuSE=wpa_supplicant Ubuntu=wpasupplicant Mandriva=wpa_supplicant Debian=wpasupplicant"
DISTRO_PN_ALIAS_pn-x11-common = "OE-Core"
DISTRO_PN_ALIAS_pn-x11perf = "Fedora=xorg-x11-apps Ubuntu=x11-apps"
-DISTRO_PN_ALIAS_pn-x11vnc = "Fedora=x11vnc Ubuntu=x11vnc"
DISTRO_PN_ALIAS_pn-xcb-util-image = "Debian=xcb-util Fedora=xcb-util"
DISTRO_PN_ALIAS_pn-xcb-util-keysyms = "Debian=xcb-util Fedora=xcb-util"
DISTRO_PN_ALIAS_pn-xcb-util-wm = "Debian=xcb-util Fedora=xcb-util"
diff --git a/meta/lib/oeqa/runtime/vnc.py b/meta/lib/oeqa/runtime/vnc.py
deleted file mode 100644
index f31deff306..0000000000
--- a/meta/lib/oeqa/runtime/vnc.py
+++ /dev/null
@@ -1,20 +0,0 @@
-from oeqa.oetest import oeRuntimeTest, skipModuleUnless
-from oeqa.utils.decorators import *
-import re
-
-def setUpModule():
- skipModuleUnless(oeRuntimeTest.hasPackage('x11vnc'), "No x11vnc package in image")
-
-class VNCTest(oeRuntimeTest):
-
- @testcase(213)
- @skipUnlessPassed('test_ssh')
- def test_vnc(self):
- (status, output) = self.target.run('x11vnc -display :0 -bg -o x11vnc.log')
- self.assertEqual(status, 0, msg="x11vnc server failed to start: %s" % output)
- port = re.search('PORT=[0-9]*', output)
- self.assertTrue(port, msg="Listening port not specified in command output: %s" %output)
-
- vncport = port.group(0).split('=')[1]
- (status, output) = self.target.run('netstat -ntl | grep ":%s"' % vncport)
- self.assertEqual(status, 0, msg="x11vnc server not running on port %s\n\n%s" % (vncport, self.target.run('netstat -ntl; cat x11vnc.log')[1]))
diff --git a/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb b/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
index b3f6830293..8ba49231d5 100644
--- a/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
+++ b/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
@@ -9,7 +9,6 @@ PR = "r33"
PACKAGE_ARCH = "${MACHINE_ARCH}"
inherit packagegroup distro_features_check
-# rdepends on x11vnc
REQUIRED_DISTRO_FEATURES = "x11"
PACKAGES = "${PN} ${PN}-base ${PN}-apps ${PN}-games"
@@ -51,7 +50,6 @@ SUMMARY_${PN}-apps = "Sato desktop - applications"
RDEPENDS_${PN}-apps = "\
leafpad \
gst-player-bin \
- x11vnc \
matchbox-terminal \
sato-screenshot \
${FILEMANAGER} \