summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-11-27 16:01:45 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-07 13:33:59 +0000
commit81ddc453d09f23eca192171e93d5aa8878852388 (patch)
treecf155b08ed35df44f9b0fae8eb9831a432c047af
parentcb89d2b25b4edb1241bc5426a69a6bc44df9be2c (diff)
downloadopenembedded-core-contrib-81ddc453d09f23eca192171e93d5aa8878852388.tar.gz
openembedded-core-contrib-81ddc453d09f23eca192171e93d5aa8878852388.tar.bz2
openembedded-core-contrib-81ddc453d09f23eca192171e93d5aa8878852388.zip
packagegroup-core-lsb: treat qt4 packages same as qt3 packages
This means issuing a warning about adding a separate layer if it is not configured. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb12
1 files changed, 11 insertions, 1 deletions
diff --git a/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb b/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
index ce823858ce..be08c580eb 100644
--- a/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
+++ b/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
@@ -225,6 +225,16 @@ QT4PKGS = " \
QT4PKGS_mips64 = ""
QT4PKGS_mips64n32 = ""
+def get_libqt4(d):
+ if 'linuxstdbase' in d.getVar('DISTROOVERRIDES', False) or "":
+ if 'qt4' in d.getVar('BBFILE_COLLECTIONS', False) or "":
+ return d.getVar('QT4PKGS', False)
+
+ bb.warn('The meta-qt4 layer should be added, this layer provides Qt 4.x' \
+ 'libraries. Its intended use is for passing LSB tests as Qt4 is' \
+ 'a requirement for LSB.')
+ return ''
+
SUMMARY_packagegroup-core-lsb-desktop = "LSB Desktop"
DESCRIPTION_packagegroup-core-lsb-desktop = "Packages required to support libraries \
specified in the LSB Desktop specification"
@@ -245,7 +255,7 @@ RDEPENDS_packagegroup-core-lsb-desktop = "\
gtk+ \
atk \
libasound \
- ${QT4PKGS} \
+ ${@get_libqt4(d)} \
${@get_libqt3(d)} \
"