aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-05-31 22:41:08 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-03 16:34:45 +0100
commit3a3d47882ac26878bdacd4d27a06bbb8fb5e1822 (patch)
treefb5d257d7d5be81bf6a808e13cad017ca937c83a
parent7c4840c7c2d7d7554c7d2f6018eb9c077be9a03f (diff)
downloadopenembedded-core-contrib-3a3d47882ac26878bdacd4d27a06bbb8fb5e1822.tar.gz
btrfs-tools: 3.18.2 -> 4.0.1
* Updated fix-parallel.patch * The 4.0.1 switched to autotools, but inherit autotools doesn't work: | make: *** No rule to make target `ctree.o', needed by `btrfs'. Stop. so inherit autotools-brokensep Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/btrfs-tools/btrfs-tools/fix-parallel.patch16
-rw-r--r--meta/recipes-devtools/btrfs-tools/btrfs-tools_git.bb16
2 files changed, 17 insertions, 15 deletions
diff --git a/meta/recipes-devtools/btrfs-tools/btrfs-tools/fix-parallel.patch b/meta/recipes-devtools/btrfs-tools/btrfs-tools/fix-parallel.patch
index 65c31a4448..bbc53c6fe1 100644
--- a/meta/recipes-devtools/btrfs-tools/btrfs-tools/fix-parallel.patch
+++ b/meta/recipes-devtools/btrfs-tools/btrfs-tools/fix-parallel.patch
@@ -11,20 +11,20 @@ Upstream-Status: Pending
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
---
- Makefile | 2 +-
+ Makefile.in | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/Makefile b/Makefile
-index 9c69ada..30c6f06 100644
---- a/Makefile
-+++ b/Makefile
-@@ -118,7 +118,7 @@ else
- AM_CFLAGS += -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2
+diff --git a/Makefile.in b/Makefile.in
+index 860a390..8a6fbd7 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -142,7 +142,7 @@ else
+ check_echo = true
endif
-%.o.d: %.c
+%.o.d: %.c version.h
- $(Q)$(CC) -MM -MG -MF $@ -MT $(@:.o.d=.o) -MT $(@:.o.d=.static.o) -MT $@ $(AM_CFLAGS) $(CFLAGS) $<
+ $(Q)$(CC) -MM -MG -MF $@ -MT $(@:.o.d=.o) -MT $(@:.o.d=.static.o) -MT $@ $(CFLAGS) $<
.c.o:
--
diff --git a/meta/recipes-devtools/btrfs-tools/btrfs-tools_git.bb b/meta/recipes-devtools/btrfs-tools/btrfs-tools_git.bb
index d86075c4c6..82403aaa14 100644
--- a/meta/recipes-devtools/btrfs-tools/btrfs-tools_git.bb
+++ b/meta/recipes-devtools/btrfs-tools/btrfs-tools_git.bb
@@ -12,19 +12,21 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067"
SECTION = "base"
DEPENDS = "util-linux attr e2fsprogs lzo acl"
-SRCREV = "344599a7aefe23c7169ccdde3ad1b921bb60024c"
+SRCREV = "c061b303c08af7a58373908d0d77ef0f1161fd36"
SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git \
file://fix-parallel.patch \
"
-S = "${WORKDIR}/git"
-
-PV = "3.18.2+git${SRCPV}"
+inherit autotools-brokensep pkgconfig
-EXTRA_OEMAKE += "DISABLE_DOCUMENTATION=1"
+EXTRA_OECONF += "--disable-documentation"
-do_install () {
- oe_runmake 'DESTDIR=${D}' install
+do_configure_prepend() {
+ sh autogen.sh
}
+S = "${WORKDIR}/git"
+
+PV = "4.0.1+git${SRCPV}"
+
BBCLASSEXTEND = "native"