aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-11-05 13:47:50 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-11-05 22:04:03 +0000
commit8d1a041891c87d0c2003c80f84b0501bdc9403a1 (patch)
tree780599b43d1e2ba1f556570099d54849f465ba17
parent8e22b08de2745e08421b38f8ba215bcc1de4b423 (diff)
downloadopenembedded-core-contrib-8d1a041891c87d0c2003c80f84b0501bdc9403a1.tar.gz
linux-yocto/3.10: fix qemuarm boot and spurious mips build warning
This update fixes two issues: a) qemuarm boot failure v3.10.13 picked up a patch for arm versatile interrupt mappings that fixes the emulator boot out of the box. But it interacts badly with our previous fix for the issue. Reverting the existing patch and going with the mainline solution fixes the boot. b) qemumips build warning and failure Depending on the build host and compiler, the build of menuconfig throws an potentially uninitialized variable warning. That warning causes an error on archs with -Werror. We can do a trivial change to avoid the warning all together (initilize it to null), and keep everyone happy. [YOCTO #5460] Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.10.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_3.10.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.10.bb14
3 files changed, 10 insertions, 10 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.10.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.10.bb
index 53d546c6f5..ab95ad13bf 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_3.10.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.10.bb
@@ -3,8 +3,8 @@ require recipes-kernel/linux/linux-yocto.inc
KBRANCH = "standard/preempt-rt/base"
KBRANCH_qemuppc = "standard/preempt-rt/qemuppc"
-SRCREV_machine ?= "919b378578a8f931ee87092f1ce2608a6c2815db"
-SRCREV_machine_qemuppc ?= "be60fd54789f04941b51665970ef121089f9b93e"
+SRCREV_machine ?= "97499dfaea61934719b91f1347f468c6f0125b2c"
+SRCREV_machine_qemuppc ?= "54cb4efa033af86301934d58d890a5324cc95a75"
SRCREV_meta ?= "f1c9080cd27f99700fa59b5375d1ddd0afe625ad"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.10.git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_3.10.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_3.10.bb
index c76951759c..c15c311647 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_3.10.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_3.10.bb
@@ -9,7 +9,7 @@ LINUX_VERSION ?= "3.10.17"
KMETA = "meta"
-SRCREV_machine ?= "375aee37c2508899b6a8c0bdff7d4d67cb75fb36"
+SRCREV_machine ?= "c03195ed6e3066494e3fb4be69154a57066e845b"
SRCREV_meta ?= "f1c9080cd27f99700fa59b5375d1ddd0afe625ad"
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.10.bb b/meta/recipes-kernel/linux/linux-yocto_3.10.bb
index af50b5c68d..eff245da81 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.10.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.10.bb
@@ -3,13 +3,13 @@ require recipes-kernel/linux/linux-yocto.inc
KBRANCH_DEFAULT = "standard/base"
KBRANCH = "${KBRANCH_DEFAULT}"
-SRCREV_machine_qemuarm ?= "47ba9c54bfa38b70e2c7500a7e30a738c667cb95"
-SRCREV_machine_qemumips ?= "b9d36bdb86b595d9823392402b31bdb76439054c"
-SRCREV_machine_qemuppc ?= "e13586324a05aba0f0cf2523ad9eecda2edd3b94"
-SRCREV_machine_qemux86 ?= "375aee37c2508899b6a8c0bdff7d4d67cb75fb36"
-SRCREV_machine_qemux86-64 ?= "375aee37c2508899b6a8c0bdff7d4d67cb75fb36"
-SRCREV_machine_qemumips64 ?= "44eaa7b02aa1e4b8e539c2227702f74f9fcbcfea"
-SRCREV_machine ?= "375aee37c2508899b6a8c0bdff7d4d67cb75fb36"
+SRCREV_machine_qemuarm ?= "5714b747cf0087bb964cbb962db8d3d2041f3177"
+SRCREV_machine_qemumips ?= "e87d2cb44bc5d10f3619871541849064bf0d79b1"
+SRCREV_machine_qemuppc ?= "3e99f981fea427696f63af7fd8e99bf05039efee"
+SRCREV_machine_qemux86 ?= "c03195ed6e3066494e3fb4be69154a57066e845b"
+SRCREV_machine_qemux86-64 ?= "c03195ed6e3066494e3fb4be69154a57066e845b"
+SRCREV_machine_qemumips64 ?= "8d21f71847640fc052bda1bf1f3792634cae5bb1"
+SRCREV_machine ?= "c03195ed6e3066494e3fb4be69154a57066e845b"
SRCREV_meta ?= "f1c9080cd27f99700fa59b5375d1ddd0afe625ad"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.10.git;bareclone=1;branch=${KBRANCH},${KMETA};name=machine,meta"