aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-11-08 16:06:38 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-11-12 10:15:00 +0000
commit55b950500fd9d944042e3c2b0872685f0a60e8eb (patch)
tree19a8c73725f6fee68f0c2173bf6967e658158c25
parent59612905e9bb865762667aa7b3cb06e53c3a4071 (diff)
downloadopenembedded-core-contrib-55b950500fd9d944042e3c2b0872685f0a60e8eb.tar.gz
glib-2.0: move more logic to the .inc
The .bb was getting larger with configuration being arbitarily split between .bb and .inc. To help adding a glib_git recipe, strip the .bb down to SRC_URI. Also don't remove $libdir/gio as it should be owned by glib. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0_2.38.1.bb47
-rw-r--r--meta/recipes-core/glib-2.0/glib.inc47
2 files changed, 43 insertions, 51 deletions
diff --git a/meta/recipes-core/glib-2.0/glib-2.0_2.38.1.bb b/meta/recipes-core/glib-2.0/glib-2.0_2.38.1.bb
index 3e874d7ff0..a5db3025bf 100644
--- a/meta/recipes-core/glib-2.0/glib-2.0_2.38.1.bb
+++ b/meta/recipes-core/glib-2.0/glib-2.0_2.38.1.bb
@@ -2,10 +2,6 @@ require glib.inc
PE = "1"
-DEPENDS += "libffi zlib"
-DEPENDS_class-native += "libffi-native"
-DEPENDS_class-nativesdk += "nativesdk-libffi nativesdk-zlib ${BPN}-native"
-
SHRT_VER = "${@oe.utils.trim_version("${PV}", 2)}"
SRC_URI = "${GNOME_MIRROR}/glib/${SHRT_VER}/glib-${PV}.tar.xz \
@@ -21,46 +17,3 @@ SRC_URI_append_class-native = " file://glib-gettextize-dir.patch"
SRC_URI[md5sum] = "f3f6789151c1810f2fe23fe9ebb8b828"
SRC_URI[sha256sum] = "01906c62ac666d2ab3183cc07261b2536fab7b211c6129ab66b119c2af56d159"
-
-BBCLASSEXTEND = "native nativesdk"
-
-RDEPENDS_${PN}-ptest += "\
- gnome-desktop-testing \
- tzdata \
- tzdata-americas \
- tzdata-asia \
- tzdata-europe \
- tzdata-posix \
- python-pygobject \
- python-dbus \
- "
-
-RDEPENDS_${PN}-ptest_append_libc-glibc = "\
- eglibc-gconv-utf-16 \
- eglibc-charmap-utf-8 \
- eglibc-gconv-cp1255 \
- eglibc-charmap-cp1255 \
- eglibc-gconv-utf-32 \
- eglibc-gconv-utf-7 \
- eglibc-charmap-invariant \
- eglibc-localedata-translit-cjk-variants \
- "
-EXTRA_OECONF_append_class-target_libc-uclibc = " --with-libiconv=gnu"
-
-do_configure_prepend() {
- sed -i -e '1s,#!.*,#!${USRBINPATH}/env python,' ${S}/gio/gdbus-2.0/codegen/gdbus-codegen.in
-}
-
-do_install_append() {
- # remove some unpackaged files
- rm -f ${D}${datadir}/glib-2.0/codegen/*.pyc
- rm -f ${D}${datadir}/glib-2.0/codegen/*.pyo
- # and empty dirs
- rm -rf ${D}${libdir}/gio
-
- # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location
- # for target as /usr/bin/perl, so fix it to /usr/bin/perl.
- if [ -f ${D}${bindir}/glib-mkenums ]; then
- sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/glib-mkenums
- fi
-}
diff --git a/meta/recipes-core/glib-2.0/glib.inc b/meta/recipes-core/glib-2.0/glib.inc
index ad0671a770..0698c29529 100644
--- a/meta/recipes-core/glib-2.0/glib.inc
+++ b/meta/recipes-core/glib-2.0/glib.inc
@@ -13,9 +13,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \
BUGTRACKER = "http://bugzilla.gnome.org"
SECTION = "libs"
-DEPENDS = "glib-2.0-native virtual/libiconv"
-DEPENDS_class-native = "pkgconfig-native gettext-native"
-DEPENDS_class-nativesdk = "nativesdk-libtool"
+BBCLASSEXTEND = "native nativesdk"
+
+DEPENDS = "glib-2.0-native virtual/libiconv libffi zlib"
+DEPENDS_class-native = "pkgconfig-native gettext-native libffi-native"
+DEPENDS_class-nativesdk = "nativesdk-libtool nativesdk-libffi nativesdk-zlib ${BPN}-native"
PACKAGES =+ "${PN}-utils ${PN}-bash-completion ${PN}-codegen"
LEAD_SONAME = "libglib-2.0.*"
@@ -30,8 +32,13 @@ CORECONF = "--disable-dtrace --disable-fam --disable-libelf --disable-systemtap
PTEST_CONF = "${@base_contains('DISTRO_FEATURES', 'ptest', '--enable-installed-tests', '--disable-installed-tests', d)}"
EXTRA_OECONF = "--enable-included-printf=no ${CORECONF} ${PTEST_CONF}"
EXTRA_OECONF_class-native = "${CORECONF} --disable-selinux"
+EXTRA_OECONF_append_class-target_libc-uclibc = " --with-libiconv=gnu"
+
+do_configure_prepend() {
+ sed -i -e '1s,#!.*,#!${USRBINPATH}/env python,' ${S}/gio/gdbus-2.0/codegen/gdbus-codegen.in
+}
-FILES_${PN} = "${libdir}/lib*${SOLIBS} ${datadir}/glib-2.0/schemas \
+FILES_${PN} = "${libdir}/lib*${SOLIBS} ${libdir}/gio ${datadir}/glib-2.0/schemas \
${datadir}/glib-2.0/gettext/mkinstalldirs ${datadir}/glib-2.0/gettext/po/Makefile.in.in"
FILES_${PN}-dev += "${libdir}/glib-2.0/include \
${libdir}/gio/modules/lib*${SOLIBSDEV} \
@@ -50,4 +57,36 @@ USE_NLS = "yes"
do_install_append () {
sed ${D}${bindir}/gtester-report -i -e '1s|^#!.*|#!/usr/bin/env python|'
+
+ # Remove some unpackaged files
+ rm -f ${D}${datadir}/glib-2.0/codegen/*.pyc
+ rm -f ${D}${datadir}/glib-2.0/codegen/*.pyo
+
+ # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location
+ # for target as /usr/bin/perl, so fix it to /usr/bin/perl.
+ if [ -f ${D}${bindir}/glib-mkenums ]; then
+ sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/glib-mkenums
+ fi
}
+
+RDEPENDS_${PN}-ptest += "\
+ gnome-desktop-testing \
+ tzdata \
+ tzdata-americas \
+ tzdata-asia \
+ tzdata-europe \
+ tzdata-posix \
+ python-pygobject \
+ python-dbus \
+ "
+
+RDEPENDS_${PN}-ptest_append_libc-glibc = "\
+ eglibc-gconv-utf-16 \
+ eglibc-charmap-utf-8 \
+ eglibc-gconv-cp1255 \
+ eglibc-charmap-cp1255 \
+ eglibc-gconv-utf-32 \
+ eglibc-gconv-utf-7 \
+ eglibc-charmap-invariant \
+ eglibc-localedata-translit-cjk-variants \
+ "