aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-03 15:49:50 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-05 15:24:04 +0000
commit07db5222a970e40bff51c5df793f0021b0e2aba8 (patch)
treee75500ec080f157c861bcbc16b4c08cc3575a9b2
parent79ea036de331bde65a88fb777647dc099ef05acf (diff)
downloadopenembedded-core-contrib-07db5222a970e40bff51c5df793f0021b0e2aba8.tar.gz
alsa-tools/autotools: Ensure that aclocal files can be present with AUTOTOOLS_COPYACLOCAL variable
Introduce a AUTOTOOLS_COPYACLOCAL variable which forces the copy of the aclocal files even when a configure.ac/.in file isn't present. Use this new feature in alsa-tools. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/classes/autotools.bbclass3
-rw-r--r--meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb6
2 files changed, 4 insertions, 5 deletions
diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass
index 01e49c98bf..b645996136 100644
--- a/meta/classes/autotools.bbclass
+++ b/meta/classes/autotools.bbclass
@@ -138,7 +138,8 @@ ACLOCALDIR = "${B}/aclocal-copy"
python autotools_copy_aclocals () {
s = d.getVar("S", True)
if not os.path.exists(s + "/configure.in") and not os.path.exists(s + "/configure.ac"):
- return
+ if not d.getVar("AUTOTOOLS_COPYACLOCAL"):
+ return
taskdepdata = d.getVar("BB_TASKDEPDATA", False)
pn = d.getVar("PN", True)
diff --git a/meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb b/meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb
index 6321b786fc..b1542332de 100644
--- a/meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb
+++ b/meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb
@@ -25,10 +25,8 @@ EXTRA_OEMAKE += "GITCOMPILE_ARGS='--host=${HOST_SYS} --build=${BUILD_SYS} --targ
PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'x11', 'gtk+', '', d)}"
PACKAGECONFIG[gtk+] = ",,gtk+,"
-do_configure () {
- autotools_do_configure
- autotools_copy_aclocal
-}
+# configure.ac/.in doesn't exist so force copy
+AUTOTOOLS_COPYACLOCAL = "1"
do_compile_prepend () {
#Automake dir is not correctly detected in cross compilation case