aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-02-15 10:02:27 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-02-15 10:02:27 +0000
commit21c112ca49407eac9808355ed286c51e26d59580 (patch)
tree2805e244a2416dc2cfe40703c999c36d086ee05c
parente5e02f3cba1b81af39f432730802e871deb53eca (diff)
parent647aaad6fb8b9c22c5287d387cb1fb691a7bd5ee (diff)
downloadopenembedded-core-contrib-21c112ca49407eac9808355ed286c51e26d59580.tar.gz
Merge branch 'srifenbark/docs' of ssh://git.pokylinux.org/poky-contrib
-rw-r--r--documentation/kernel-manual/kernel-how-to.xml33
-rw-r--r--documentation/yocto-project-qs/yocto-project-qs.xml11
2 files changed, 30 insertions, 14 deletions
diff --git a/documentation/kernel-manual/kernel-how-to.xml b/documentation/kernel-manual/kernel-how-to.xml
index 6b326b5561..c3c9569adf 100644
--- a/documentation/kernel-manual/kernel-how-to.xml
+++ b/documentation/kernel-manual/kernel-how-to.xml
@@ -882,7 +882,7 @@ repository.
The following commands illustrate how you can condense and merge two BSPs into a second SCM:
<literallayout class='monospaced'>
&gt; git checkout common_pc-standard
- &gt; git merge cav_ebt5800-standard
+ &gt; git merge common_pc_64-standard
# resolve any conflicts and commit them
&gt; cd .. ; echo linux/.git &gt; .cvsignore
&gt; cvs import -m "initial import" linux MY_COMPANY start
@@ -1054,7 +1054,7 @@ That's it. Configure and build.
For this example the only thing left was the kernel directory with a
<filename>linux-yocto_git.bbappend</filename> file (linux-yocto is the kernel listed in
<filename>meta-crownbay/conf/machine/crownbay.conf</filename></para></listitem>.
- <listitem><para>Add a new entry in the <filename>build/donf/bblayers.conf</filename>
+ <listitem><para>Add a new entry in the <filename>build/conf/bblayers.conf</filename>
so the new layer can be found by Bitbake.</para></listitem>
</itemizedlist>
</para></listitem>
@@ -1088,21 +1088,26 @@ That's it. Configure and build.
</para></listitem>
<listitem><para>
- Point the build at the new kernel git tree.
- </para>
+ In a layer, create a <filename>linux-yocto_git.bbappend</filename>
+ file with the following:
+ </para>
<para>
- You can do this by commenting out the SRC_URI variable in
- <filename>meta/recipes-kernel/linux/linux-yocto_git.bb</filename> and using a SRC_URI
- that points to your new bare git tree.
- You should also be able to do this in <filename>linux-yocto_git.bbappend</filename> in the layer:
<literallayout class='monospaced'>
- # To use a staged, on-disk bare clone of a Wind River Kernel, use a variant of the
- # below SRC_URI = "git://///path/to/kernel/default_kernel.git;fullclone=1"
- #
- SRC_URI = "git://git.pokylinux.org/linux-2.6-windriver.git;protocol=git;fullclone=1;branch=${KBRANCH};name=machine
-\
- git://git.pokylinux.org/linux-2.6-windriver.git;protocol=git;noclone=1;branch=wrs_meta;name=meta"
+ COMPATIBLE_MACHINE = ${MACHINE}
+
+ # It is often nice to have a local clone of the kernel repository, to
+ # allow patches to be staged, branches created, and so forth. Modify
+ # KSRC to point to your local clone as appropriate.
+
+ # KSRC ?= /path/to/your/bare/clone/yocto-kernel
+
+ # KMACHINE is the branch to be built, or alternateively
+ # KBRANCH can be directly set.
+
+ # KBRANCH ?= "${KMACHINE}-${LINUX_KERNEL_TYPE}"
+
+ # SRC_URI = "git://${KSRC};nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
</literallayout>
</para>
diff --git a/documentation/yocto-project-qs/yocto-project-qs.xml b/documentation/yocto-project-qs/yocto-project-qs.xml
index 24480bc787..56dafe5e0a 100644
--- a/documentation/yocto-project-qs/yocto-project-qs.xml
+++ b/documentation/yocto-project-qs/yocto-project-qs.xml
@@ -234,6 +234,17 @@
$ source poky-laverne-4.0/poky-init-build-env poky-4.0-build
</literallayout>
</para>
+
+ <tip><para>
+ To help conserve disk space during builds you can add the following statement
+ to your <filename>local.conf</filename> file.
+ Adding this statement deletes the work directory used for building a package
+ once the package is built.
+ <literallayout class='monospaced'>
+ INHERIT += "rm_work"
+ </literallayout>
+ </para></tip>
+
<itemizedlist>
<listitem><para>The first two commands extract the Yocto Project files from the
release tarball and place them into a subdirectory of your current directory.</para></listitem>