aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/python-pyparted/python-pyparted.inc12
-rw-r--r--recipes-extended/python-pyparted/python-pyparted/0001-fix-version-float-check.patch26
-rw-r--r--recipes-extended/python-pyparted/python-pyparted_3.11.1.bb (renamed from recipes-extended/python-pyparted/python-pyparted_3.10.7.bb)0
3 files changed, 7 insertions, 31 deletions
diff --git a/recipes-extended/python-pyparted/python-pyparted.inc b/recipes-extended/python-pyparted/python-pyparted.inc
index 65f8ca1..2192179 100644
--- a/recipes-extended/python-pyparted/python-pyparted.inc
+++ b/recipes-extended/python-pyparted/python-pyparted.inc
@@ -11,11 +11,13 @@ LIC_FILES_CHKSUM = "\
DEPENDS += "parted"
# upstream only publishes releases in github archives which are discouraged
-SRCREV = "69c4a478e43d3eff6ae3a0116fa38da06776d5f5"
-SRC_URI = "git://github.com/rhinstaller/pyparted.git;protocol=https \
- file://0001-fix-version-float-check.patch \
-"
+SRCREV = "1fdb15120f35f5da1dc7ec116522f0c796a8376a"
+SRC_URI = "git://github.com/rhinstaller/pyparted.git;protocol=https"
+
S = "${WORKDIR}/git"
-RDEPENDS_${PN} += "parted (>= 2.3)"
+RDEPENDS_${PN}_class-target += " \
+ parted (>= 2.3) \
+ ${PYTHON_PN}-subprocess \
+"
RDEPENDS_${PN}_class-native = ""
diff --git a/recipes-extended/python-pyparted/python-pyparted/0001-fix-version-float-check.patch b/recipes-extended/python-pyparted/python-pyparted/0001-fix-version-float-check.patch
deleted file mode 100644
index db3ab9f..0000000
--- a/recipes-extended/python-pyparted/python-pyparted/0001-fix-version-float-check.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-check_mod_version breaks if module version is of x.y.z form
-use a regex to help cast x.y.z version to a float
-
-Upstream-Status: Pending
-
-Index: git/setup.py
-===================================================================
---- git.orig/setup.py
-+++ git/setup.py
-@@ -25,6 +25,7 @@ import glob
- import os
- import platform
- import sys
-+import re
- from distutils.ccompiler import new_compiler
- from distutils.errors import CompileError
- from distutils.errors import LinkError
-@@ -51,6 +52,8 @@ def pkgconfig(*packages, **kwargs):
-
- def check_mod_version(module, version):
- modversion = subprocess.check_output(["pkg-config", "--modversion", module])
-+ match = re.search('([0-9]+\.[0-9]+)', modversion)
-+ modversion = match.group(0)
- if not float(modversion) >= float(version):
- sys.stderr.write("*** Minimum required %s version: %s, found: %s\n" % (module, version, modversion,))
- sys.exit(1)
diff --git a/recipes-extended/python-pyparted/python-pyparted_3.10.7.bb b/recipes-extended/python-pyparted/python-pyparted_3.11.1.bb
index 81d61c6..81d61c6 100644
--- a/recipes-extended/python-pyparted/python-pyparted_3.10.7.bb
+++ b/recipes-extended/python-pyparted/python-pyparted_3.11.1.bb