aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-six_1.9.0.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-six_1.9.0.bb b/recipes-devtools/python/python-six_1.9.0.bb
index aa96dc9..c6575f3 100644
--- a/recipes-devtools/python/python-six_1.9.0.bb
+++ b/recipes-devtools/python/python-six_1.9.0.bb
@@ -6,3 +6,11 @@ SRC_URI[md5sum] = "476881ef4012262dfc8adc645ee786c4"
SRC_URI[sha256sum] = "e24052411fc4fbd1f672635537c3fc2330d9481b18c0317695b46259512c91d5"
inherit pypi
+
+do_compile_append() {
+ export BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS}
+ ${PYTHON} setup.py -q bdist_egg --dist-dir ./
+}
+do_install_append() {
+ install -m 0644 ${S}/*.egg ${D}/${PYTHON_SITEPACKAGES_DIR}/
+}