aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-lxml_4.4.2.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/recipes-devtools/python/python-lxml_4.4.2.bb b/recipes-devtools/python/python-lxml_4.4.2.bb
index 911ba58..51ba4b8 100644
--- a/recipes-devtools/python/python-lxml_4.4.2.bb
+++ b/recipes-devtools/python/python-lxml_4.4.2.bb
@@ -21,6 +21,10 @@ SRC_URI[sha256sum] = "eff69ddbf3ad86375c344339371168640951c302450c5d3e9936e98d64
DEPENDS += "libxml2 libxslt"
+inherit pypi setuptools
+
+# add to the defaults which are set in the setuptools bbclass
+#
DISTUTILS_BUILD_ARGS += " \
--with-xslt-config='pkg-config libxslt' \
--with-xml2-config='pkg-config libxml-2.0' \
@@ -31,8 +35,6 @@ DISTUTILS_INSTALL_ARGS += " \
--with-xml2-config='pkg-config libxml-2.0' \
"
-inherit pypi setuptools
-
# {standard input}: Assembler messages:
# {standard input}:1488805: Error: branch out of range
DEBUG_OPTIMIZATION_remove_mips = " -Og"