aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python_2.7.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python_2.7.18.bb')
-rw-r--r--recipes-devtools/python/python_2.7.18.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-devtools/python/python_2.7.18.bb b/recipes-devtools/python/python_2.7.18.bb
index c28c010..658671f 100644
--- a/recipes-devtools/python/python_2.7.18.bb
+++ b/recipes-devtools/python/python_2.7.18.bb
@@ -258,3 +258,9 @@ addtask do_create_manifest
# Make sure we have native python ready when we create a new manifest
do_create_manifest[depends] += "${PN}:do_prepare_recipe_sysroot"
do_create_manifest[depends] += "${PN}:do_patch"
+
+# Python's tests contain large numbers of files we don't need in the recipe sysroots
+SYSROOT_PREPROCESS_FUNCS += " py_sysroot_cleanup"
+py_sysroot_cleanup () {
+ rm -rf ${SYSROOT_DESTDIR}${libdir}/python${PYTHON_MAJMIN}/test
+}