aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python/avoid_warning_for_sunos_specific_module.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python/avoid_warning_for_sunos_specific_module.patch')
-rw-r--r--recipes-devtools/python/python/avoid_warning_for_sunos_specific_module.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-devtools/python/python/avoid_warning_for_sunos_specific_module.patch b/recipes-devtools/python/python/avoid_warning_for_sunos_specific_module.patch
new file mode 100644
index 0000000..8ba5823
--- /dev/null
+++ b/recipes-devtools/python/python/avoid_warning_for_sunos_specific_module.patch
@@ -0,0 +1,23 @@
+sunaudiodev module is sunos specific so we avoid a warning by not
+adding this module to missing variable.
+
+Upstream-Status: Inappropriate [distribution]
+
+Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
+
+Index: Python-2.7.13/setup.py
+===================================================================
+--- Python-2.7.13.orig/setup.py
++++ Python-2.7.13/setup.py
+@@ -1671,8 +1671,9 @@ class PyBuildExt(build_ext):
+ if host_platform == 'sunos5':
+ # SunOS specific modules
+ exts.append( Extension('sunaudiodev', ['sunaudiodev.c']) )
+- else:
+- missing.append('sunaudiodev')
++ # If platform is not sunos warning is useless
++ #else:
++ # missing.append('sunaudiodev')
+
+ if host_platform == 'darwin':
+ # _scproxy