aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-waitress_1.4.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python-waitress_1.4.2.bb')
-rw-r--r--recipes-devtools/python/python-waitress_1.4.2.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-waitress_1.4.2.bb b/recipes-devtools/python/python-waitress_1.4.2.bb
new file mode 100644
index 0000000..109f222
--- /dev/null
+++ b/recipes-devtools/python/python-waitress_1.4.2.bb
@@ -0,0 +1,19 @@
+SUMMARY = "A WSGI server for Python"
+DESCRIPTION = "Waitress is meant to be a production-quality pure-Python WSGI \
+ server with very acceptable performance."
+HOMEPAGE = "https://github.com/Pylons/waitress"
+SECTION = "devel/python"
+LICENSE = "ZPL-2.1"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=78ccb3640dc841e1baecb3e27a6966b2"
+
+SRC_URI[md5sum] = "fdeed7ec32bbba011e90801208378c89"
+SRC_URI[sha256sum] = "67a60a376f0eb335ed88967c42b73983a58d66a2a72eb9009a42725f7453b142"
+
+inherit setuptools pypi
+
+RDEPENDS_${PN}_append_class-target = "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-re \
+ "