aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-ujson_1.33.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python-ujson_1.33.bb')
-rw-r--r--recipes-devtools/python/python-ujson_1.33.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-ujson_1.33.bb b/recipes-devtools/python/python-ujson_1.33.bb
new file mode 100644
index 0000000..8fdd2b8
--- /dev/null
+++ b/recipes-devtools/python/python-ujson_1.33.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Ultra fast JSON encoder and decoder for Python"
+DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pure C with bindings for Python 2.5+ and 3."
+HOMEPAGE = "https://pypi.python.org/pypi/ujson"
+
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=5b206f6ba5e41c60df8cdcddf79a3d82"
+
+SRCNAME = "ujson"
+
+SRC_URI = " \
+ http://pypi.python.org/packages/source/u/ujson/${SRCNAME}-${PV}.zip \
+"
+
+SRC_URI[md5sum] = "8148a2493fff78940feab1e11dc0a893"
+SRC_URI[sha256sum] = "68cf825f227c82e1ac61e423cfcad923ff734c27b5bdd7174495d162c42c602b"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+RDEPENDS_${PN} += "python-numbers"