aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-socketio_4.3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python-socketio_4.3.1.bb')
-rw-r--r--recipes-devtools/python/python-socketio_4.3.1.bb30
1 files changed, 28 insertions, 2 deletions
diff --git a/recipes-devtools/python/python-socketio_4.3.1.bb b/recipes-devtools/python/python-socketio_4.3.1.bb
index e25a6b3..44cde08 100644
--- a/recipes-devtools/python/python-socketio_4.3.1.bb
+++ b/recipes-devtools/python/python-socketio_4.3.1.bb
@@ -1,2 +1,28 @@
-inherit setuptools
-require python-socketio.inc
+SUMMARY = "Socket.IO server"
+HOMEPAGE = "https://github.com/miguelgrinberg/python-socketio/"
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=42d0a9e728978f0eeb759c3be91536b8"
+
+inherit pypi setuptools
+
+PYPI_PACKAGE = "python-socketio"
+
+SRC_URI[md5sum] = "86cd47dddea1785ce7a6c72f55c93fe7"
+SRC_URI[sha256sum] = "506b2cf7a520b40ea0b3f25e1272eff8de134dce6f471c1f6bc0de8c90fe8c57"
+
+PACKAGECONFIG ?= ""
+PACKAGECONFIG[asyncio_client] = ",,,${PYTHON_PN}-aiohttp ${PYTHON_PN}-websockets"
+PACKAGECONFIG[client] = ",,,${PYTHON_PN}-requests ${PYTHON_PN}-websocket-client"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-engineio \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-math \
+ ${PYTHON_PN}-pickle \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-attrs \
+ "