aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-simplejson_3.16.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python-simplejson_3.16.0.bb')
-rw-r--r--recipes-devtools/python/python-simplejson_3.16.0.bb28
1 files changed, 25 insertions, 3 deletions
diff --git a/recipes-devtools/python/python-simplejson_3.16.0.bb b/recipes-devtools/python/python-simplejson_3.16.0.bb
index 24ad9a9..1c71da5 100644
--- a/recipes-devtools/python/python-simplejson_3.16.0.bb
+++ b/recipes-devtools/python/python-simplejson_3.16.0.bb
@@ -1,4 +1,26 @@
-inherit setuptools
-require python-simplejson.inc
+SUMMARY = "Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE = "http://cheeseshop.python.org/pypi/simplejson"
-RDEPENDS_${PN} += "${PYTHON_PN}-re"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c6338d7abd321c0b50a2a547e441c52e"
+
+SRC_URI[md5sum] = "744fa99aed207478f8fbf9dd9f04fad3"
+SRC_URI[sha256sum] = "b1f329139ba647a9548aa05fb95d046b4a677643070dc2afc05fa2e975d09ca5"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-netserver \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-re \
+"
+
+PACKAGES =+ "${PN}-tests"
+RDEPENDS_${PN}-tests = "${PN} ${PYTHON_PN}-unittest"
+FILES_${PN}-tests+= " \
+ ${PYTHON_SITEPACKAGES_DIR}/simplejson/tests \
+ ${PYTHON_SITEPACKAGES_DIR}/simplejson/tool.py* \
+"
+
+BBCLASSEXTEND = "native nativesdk"