aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-pytest-runner_2.11.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python-pytest-runner_2.11.1.bb')
-rw-r--r--recipes-devtools/python/python-pytest-runner_2.11.1.bb17
1 files changed, 4 insertions, 13 deletions
diff --git a/recipes-devtools/python/python-pytest-runner_2.11.1.bb b/recipes-devtools/python/python-pytest-runner_2.11.1.bb
index 188ef2b..0a5055c 100644
--- a/recipes-devtools/python/python-pytest-runner_2.11.1.bb
+++ b/recipes-devtools/python/python-pytest-runner_2.11.1.bb
@@ -1,14 +1,5 @@
-SUMMARY = "Invoke py.test as distutils command with dependency resolution"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=e38b971c2b4c33b978d1b9c9ece9ae63"
+inherit setuptools
+require python-pytest-runner.inc
-SRC_URI[md5sum] = "bdb73eb18eca2727944a2dcf963c5a81"
-SRC_URI[sha256sum] = "983a31eab45e375240e250161a556163bc8d250edaba97960909338c273a89b3"
-
-DEPENDS += " \
- python-setuptools-scm"
-
-RDEPENDS_${PN} = "python-py python-setuptools python-argparse python-debugger python-json \
- python-compiler python-io"
-
-inherit pypi setuptools
+# Dependency only exists for python2
+RDEPENDS_${PN} += "python-compiler"