aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-pyrsistent_0.15.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python-pyrsistent_0.15.7.bb')
-rw-r--r--recipes-devtools/python/python-pyrsistent_0.15.7.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-pyrsistent_0.15.7.bb b/recipes-devtools/python/python-pyrsistent_0.15.7.bb
new file mode 100644
index 0000000..acfcb12
--- /dev/null
+++ b/recipes-devtools/python/python-pyrsistent_0.15.7.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Persistent/Immutable/Functional data structures for Python"
+HOMEPAGE = "https://github.com/tobgu/pyrsistent"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENCE.mit;md5=ca574f2891cf528b3e7a2ee570337e7c"
+
+SRC_URI[md5sum] = "da9486d00ef5b213f40d5cf3c5bca82d"
+SRC_URI[sha256sum] = "cdc7b5e3ed77bed61270a47d35434a30617b9becdf2478af76ad2c6ade307280"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-six \
+"
+
+BBCLASSEXTEND = "native nativesdk"