aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-pygobject_3.34.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python-pygobject_3.34.0.bb')
-rw-r--r--recipes-devtools/python/python-pygobject_3.34.0.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes-devtools/python/python-pygobject_3.34.0.bb b/recipes-devtools/python/python-pygobject_3.34.0.bb
index d825f05..2e9cacd 100644
--- a/recipes-devtools/python/python-pygobject_3.34.0.bb
+++ b/recipes-devtools/python/python-pygobject_3.34.0.bb
@@ -22,7 +22,7 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
UNKNOWN_CONFIGURE_WHITELIST = "introspection"
-EXTRA_OEMESON_append = " -Dpython=python2"
+EXTRA_OEMESON:append = " -Dpython=python2"
PACKAGECONFIG ??= "stagedir"
@@ -31,10 +31,10 @@ PACKAGECONFIG[tests] = "-Dtests=true, -Dtests=false, , "
PACKAGECONFIG[stagedir] = "-Dstagedir=${PYTHON_SITEPACKAGES_DIR}, -Dstagedir="", , "
BBCLASSEXTEND = "native"
-RDEPENDS_${PN} = "python-io python-pkgutil"
-RDEPENDS_${PN}_class-native = ""
+RDEPENDS:${PN} = "python-io python-pkgutil"
+RDEPENDS:${PN}:class-native = ""
-do_install_append() {
+do_install:append() {
# Remove files that clash with python3-pygobject; their content is same
rm -r ${D}${includedir}/pygobject-3.0/pygobject.h ${D}${libdir}/pkgconfig
}