aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-pbr_5.4.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python-pbr_5.4.4.bb')
-rw-r--r--recipes-devtools/python/python-pbr_5.4.4.bb14
1 files changed, 11 insertions, 3 deletions
diff --git a/recipes-devtools/python/python-pbr_5.4.4.bb b/recipes-devtools/python/python-pbr_5.4.4.bb
index 9d7d8d7..fb0949e 100644
--- a/recipes-devtools/python/python-pbr_5.4.4.bb
+++ b/recipes-devtools/python/python-pbr_5.4.4.bb
@@ -1,13 +1,21 @@
-inherit setuptools
-# The inc file is in oe-core
-require recipes-devtools/python/python-pbr.inc
+SUMMARY = "Python Build Reasonableness"
+DESCRIPTION = "PBR is a library that injects some useful and sensible default behaviors into your setuptools run"
+HOMEPAGE = "https://pypi.python.org/pypi/pbr"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
SRC_URI[md5sum] = "65cdc32e1a1ff56d481fc15aa8caf988"
SRC_URI[sha256sum] = "139d2625547dbfa5fb0b81daebb39601c478c21956dc57e2e07b74450a8c506b"
+inherit pypi setuptools
+
+RDEPENDS_${PN} += "${PYTHON_PN}-pip"
+
do_install_append() {
if [ -f ${D}${bindir}/pbr ]; then
mv ${D}${bindir}/pbr ${D}${bindir}/pbr-2
fi
}
+BBCLASSEXTEND = "native nativesdk"