aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-m2crypto_0.30.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python-m2crypto_0.30.1.bb')
-rw-r--r--recipes-devtools/python/python-m2crypto_0.30.1.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-devtools/python/python-m2crypto_0.30.1.bb b/recipes-devtools/python/python-m2crypto_0.30.1.bb
index 25b02d8..22bf56a 100644
--- a/recipes-devtools/python/python-m2crypto_0.30.1.bb
+++ b/recipes-devtools/python/python-m2crypto_0.30.1.bb
@@ -34,7 +34,7 @@ export SWIG_FEATURES
#
do_configure_prepend() {
${CPP} -dM - < /dev/null | grep -v '__\(STDC\|REGISTER_PREFIX\|GNUC\|STDC_HOSTED\)__' \
- | sed 's/^\(#define \([^ ]*\) .*\)$/#undef \2\n\1/' > SWIG/gcc_macros.h
+ | sed 's/^\(#define \([^ ]*\) .*\)$/#undef \2\n\1/' > ${S}/SWIG/gcc_macros.h
if [ "${SITEINFO_BITS}" = "64" ];then
bit="64"
@@ -44,11 +44,11 @@ do_configure_prepend() {
if [ -e ${STAGING_INCDIR}/openssl/opensslconf-${bit}.h ] ;then
for i in SWIG/_ec.i SWIG/_evp.i; do
- sed -i -e "s/opensslconf.*\./opensslconf-${bit}\./" "$i"
+ sed -i -e "s/opensslconf.*\./opensslconf-${bit}\./" "${S}/$i"
done
elif [ -e ${STAGING_INCDIR}/openssl/opensslconf-n${bit}.h ] ;then
for i in SWIG/_ec.i SWIG/_evp.i; do
- sed -i -e "s/opensslconf.*\./opensslconf-n${bit}\./" "$i"
+ sed -i -e "s/opensslconf.*\./opensslconf-n${bit}\./" "${S}/$i"
done
fi
}