aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-evdev_1.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python-evdev_1.2.0.bb')
-rw-r--r--recipes-devtools/python/python-evdev_1.2.0.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-devtools/python/python-evdev_1.2.0.bb b/recipes-devtools/python/python-evdev_1.2.0.bb
index ef6f2dc..b030f61 100644
--- a/recipes-devtools/python/python-evdev_1.2.0.bb
+++ b/recipes-devtools/python/python-evdev_1.2.0.bb
@@ -3,14 +3,14 @@ HOMEPAGE = "https://github.com/gvalkov/python-evdev"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=18debddbb3f52c661a129724a883a8e2"
-FILESEXTRAPATHS_prepend := "${THISDIR}/python-evdev:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/python-evdev:"
SRC_URI += " file://0001-Fix-build-on-32bit-arches-with-64bit-time_t.patch"
SRC_URI[md5sum] = "53e440943dfa2514f95b3c448d6a36cb"
SRC_URI[sha256sum] = "b03f5e1be5b4a5327494a981b831d251a142b09e8778eda1a8b53eba91100166"
-do_compile_prepend() {
+do_compile:prepend() {
rm -rf ${S}/evdev/ecodes.c
}
@@ -18,7 +18,7 @@ DISTUTILS_BUILD_ARGS = "build_ecodes --evdev-headers ${STAGING_DIR_TARGET}/usr/i
inherit pypi setuptools
-RDEPENDS_${PN} += "\
+RDEPENDS:${PN} += "\
${PYTHON_PN}-ctypes \
${PYTHON_PN}-fcntl \
${PYTHON_PN}-io \