aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-deprecated_1.2.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python-deprecated_1.2.7.bb')
-rw-r--r--recipes-devtools/python/python-deprecated_1.2.7.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-deprecated_1.2.7.bb b/recipes-devtools/python/python-deprecated_1.2.7.bb
new file mode 100644
index 0000000..da2c760
--- /dev/null
+++ b/recipes-devtools/python/python-deprecated_1.2.7.bb
@@ -0,0 +1,16 @@
+SUMMARY = "Python @deprecated decorator to deprecate old python classes, functions or methods."
+HOMEPAGE = "https://github.com/tantale/deprecated"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=44288e26f4896bdab14072d4fa35ff01"
+
+SRC_URI[md5sum] = "93d65f6a4efc9aebebfd28c9413dfd19"
+SRC_URI[sha256sum] = "408038ab5fdeca67554e8f6742d1521cd3cd0ee0ff9d47f29318a4f4da31c308"
+
+PYPI_PACKAGE = "Deprecated"
+
+inherit pypi setuptools
+
+S = "${WORKDIR}/${PYPI_PACKAGE}-${PV}"
+
+RDEPENDS_${PN} += "python-wrapt"