aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-cmd2_0.9.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python-cmd2_0.9.2.bb')
-rw-r--r--recipes-devtools/python/python-cmd2_0.9.2.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-cmd2_0.9.2.bb b/recipes-devtools/python/python-cmd2_0.9.2.bb
new file mode 100644
index 0000000..74dbaef
--- /dev/null
+++ b/recipes-devtools/python/python-cmd2_0.9.2.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Extra features for standard library's cmd module"
+HOMEPAGE = "http://packages.python.org/cmd2/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://setup.py;beginline=52;endline=52;md5=0f13c9cfc75288223cf7edd2f3b985a2"
+
+SRC_URI[md5sum] = "bfe0900a2288283a40f0ee7533486a2f"
+SRC_URI[sha256sum] = "e7b6b4b76272a051c943c3c709cd760142af16fbc9218e0ed3c22b28ea38d0a8"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-doctest \
+ ${PYTHON_PN}-pyparsing \
+ ${PYTHON_PN}-pyperclip \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-stringold \
+ ${PYTHON_PN}-subprocess \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-textutils \
+ "