aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-cmd2_0.9.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python-cmd2_0.9.2.bb')
-rw-r--r--recipes-devtools/python/python-cmd2_0.9.2.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-cmd2_0.9.2.bb b/recipes-devtools/python/python-cmd2_0.9.2.bb
new file mode 100644
index 0000000..1b75e34
--- /dev/null
+++ b/recipes-devtools/python/python-cmd2_0.9.2.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Extra features for standard library's cmd module"
+HOMEPAGE = "http://packages.python.org/cmd2/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=60bc6842001870a418935bd84570b676"
+
+SRC_URI[md5sum] = "bfe0900a2288283a40f0ee7533486a2f"
+SRC_URI[sha256sum] = "e7b6b4b76272a051c943c3c709cd760142af16fbc9218e0ed3c22b28ea38d0a8"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-doctest \
+ ${PYTHON_PN}-pyparsing \
+ ${PYTHON_PN}-pyperclip \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-stringold \
+ ${PYTHON_PN}-subprocess \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-textutils \
+ "
+
+BBCLASSEXTEND = "native nativesdk"