aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-aws-iot-device-sdk-python_1.4.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python-aws-iot-device-sdk-python_1.4.7.bb')
-rw-r--r--recipes-devtools/python/python-aws-iot-device-sdk-python_1.4.7.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/recipes-devtools/python/python-aws-iot-device-sdk-python_1.4.7.bb b/recipes-devtools/python/python-aws-iot-device-sdk-python_1.4.7.bb
index f067c88..b3fd1a5 100644
--- a/recipes-devtools/python/python-aws-iot-device-sdk-python_1.4.7.bb
+++ b/recipes-devtools/python/python-aws-iot-device-sdk-python_1.4.7.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "https://github.com/aws/aws-iot-device-sdk-python"
SECTION = "devel/python"
LICENSE = "Apache-2.0 & (EPL-1.0 | EDL-1.0)"
-LICENSE_${PN}-examples = "Apache-2.0"
+LICENSE:${PN}-examples = "Apache-2.0"
LIC_FILES_CHKSUM = "\
file://LICENSE.txt;md5=9ac49901b833e769c7d6f21e8dbd7b30 \
file://AWSIoTPythonSDK/core/protocol/paho/client.py;endline=14;md5=5a3c8a1a4bb71bd934f450ecff972ad9 \
@@ -17,7 +17,7 @@ inherit pypi setuptools
PYPI_PACKAGE = "AWSIoTPythonSDK"
-do_install_append() {
+do_install:append() {
install -d -m0755 ${D}${datadir}/${BPN}/examples
cp --preserve=mode,timestamps -R ${S}/samples/* ${D}${datadir}/${BPN}/examples
# this requires the full blown AWS Python SDK
@@ -26,7 +26,7 @@ do_install_append() {
PACKAGES =+ "${PN}-examples"
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
${PYTHON_PN}-crypt \
${PYTHON_PN}-datetime \
${PYTHON_PN}-io \
@@ -38,9 +38,9 @@ RDEPENDS_${PN} += " \
${PYTHON_PN}-threading \
"
-RDEPENDS_${PN}-examples += "${PN} ${PYTHON_PN}-argparse"
+RDEPENDS:${PN}-examples += "${PN} ${PYTHON_PN}-argparse"
-FILES_${PN}-examples = "${datadir}/${BPN}/examples"
+FILES:${PN}-examples = "${datadir}/${BPN}/examples"
BBCLASSEXTEND = "native nativesdk"