aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/images/meta-python2-image-base.bb2
-rw-r--r--recipes-core/images/meta-python2-image.bb2
-rw-r--r--recipes-core/images/meta-python2-ptest-image.bb2
-rw-r--r--recipes-core/packagegroups/packagegroup-meta-python2.bb2
4 files changed, 8 insertions, 0 deletions
diff --git a/recipes-core/images/meta-python2-image-base.bb b/recipes-core/images/meta-python2-image-base.bb
index 6b43def..834e928 100644
--- a/recipes-core/images/meta-python2-image-base.bb
+++ b/recipes-core/images/meta-python2-image-base.bb
@@ -5,3 +5,5 @@ IMAGE_INSTALL = "packagegroup-core-boot"
LICENSE = "MIT"
inherit core-image
+
+PNBLACKLIST[meta-python2-image-base.bb] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"
diff --git a/recipes-core/images/meta-python2-image.bb b/recipes-core/images/meta-python2-image.bb
index 9fe75ea..ff3113e 100644
--- a/recipes-core/images/meta-python2-image.bb
+++ b/recipes-core/images/meta-python2-image.bb
@@ -3,3 +3,5 @@ require meta-python2-image-base.bb
SUMMARY = "meta-python2 build test image"
IMAGE_INSTALL += "packagegroup-meta-python2"
+
+PNBLACKLIST[meta-python2-image.bb] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"
diff --git a/recipes-core/images/meta-python2-ptest-image.bb b/recipes-core/images/meta-python2-ptest-image.bb
index ddf5664..8f9db14 100644
--- a/recipes-core/images/meta-python2-ptest-image.bb
+++ b/recipes-core/images/meta-python2-ptest-image.bb
@@ -3,3 +3,5 @@ require meta-python2-image-base.bb
SUMMARY = "meta-python2 ptest test image"
IMAGE_INSTALL += "packagegroup-meta-python2-ptest"
+
+PNBLACKLIST[meta-python2-ptest-image.bb] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"
diff --git a/recipes-core/packagegroups/packagegroup-meta-python2.bb b/recipes-core/packagegroups/packagegroup-meta-python2.bb
index 5891cc9..45f2ed7 100644
--- a/recipes-core/packagegroups/packagegroup-meta-python2.bb
+++ b/recipes-core/packagegroups/packagegroup-meta-python2.bb
@@ -89,3 +89,5 @@ RDEPENDS_packagegroup-meta-python2-ptest = "\
"
EXCLUDE_FROM_WORLD = "1"
+
+PNBLACKLIST[packagegroup-meta-python2.bb] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"