aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/python/python-toml.inc10
-rw-r--r--recipes-devtools/python/python-toml_0.10.0.bb6
2 files changed, 16 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-toml.inc b/recipes-devtools/python/python-toml.inc
new file mode 100644
index 0000000..a3b3dfc
--- /dev/null
+++ b/recipes-devtools/python/python-toml.inc
@@ -0,0 +1,10 @@
+SUMMARY = "Python Library for Tom's Obvious, Minimal Language"
+HOMEPAGE = "https://github.com/uiri/toml"
+LICENSE = "MIT"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6d6012eea477117abf51c31262a152f8"
+
+SRC_URI[md5sum] = "63fffbe2d632865ec29cd69bfdf36682"
+SRC_URI[sha256sum] = "229f81c57791a41d65e399fc06bf0848bab550a9dfd5ed66df18ce5f05e73d5c"
+
+inherit pypi
diff --git a/recipes-devtools/python/python-toml_0.10.0.bb b/recipes-devtools/python/python-toml_0.10.0.bb
new file mode 100644
index 0000000..3c4acce
--- /dev/null
+++ b/recipes-devtools/python/python-toml_0.10.0.bb
@@ -0,0 +1,6 @@
+inherit setuptools
+require python-toml.inc
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-datetime \
+"