aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/python/python-pytest-tempdir.inc10
-rw-r--r--recipes-devtools/python/python-pytest-tempdir_2016.8.20.bb11
2 files changed, 12 insertions, 9 deletions
diff --git a/recipes-devtools/python/python-pytest-tempdir.inc b/recipes-devtools/python/python-pytest-tempdir.inc
new file mode 100644
index 0000000..196f6d6
--- /dev/null
+++ b/recipes-devtools/python/python-pytest-tempdir.inc
@@ -0,0 +1,10 @@
+DESCRIPTION = "Adds support for a predictable and repeatable temporary directory."
+HOMEPAGE = "https://github.com/saltstack/pytest-tempdir"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=8751a9cf4a70be4f02697a9b89e686ce"
+
+SRC_URI[md5sum] = "f87f2583f5f8aaca7203d57ada3948b5"
+SRC_URI[sha256sum] = "65ff815966ea6dfc07ca1b43747c9888a6d883971170e67b16290f9f50d434ea"
+
+inherit pypi
diff --git a/recipes-devtools/python/python-pytest-tempdir_2016.8.20.bb b/recipes-devtools/python/python-pytest-tempdir_2016.8.20.bb
index 74030dc..8a9b83e 100644
--- a/recipes-devtools/python/python-pytest-tempdir_2016.8.20.bb
+++ b/recipes-devtools/python/python-pytest-tempdir_2016.8.20.bb
@@ -1,13 +1,6 @@
-DESCRIPTION = "Adds support for a predictable and repeatable temporary directory."
-HOMEPAGE = "https://github.com/saltstack/pytest-tempdir"
-SECTION = "devel/python"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://PKG-INFO;md5=8751a9cf4a70be4f02697a9b89e686ce"
+require python-pytest-tempdir.inc
-SRC_URI[md5sum] = "f87f2583f5f8aaca7203d57ada3948b5"
-SRC_URI[sha256sum] = "65ff815966ea6dfc07ca1b43747c9888a6d883971170e67b16290f9f50d434ea"
-
-inherit pypi setuptools
+inherit setuptools
RDEPENDS_${PN} += " \
python-pytest \